[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC2 test1: pcmcia problems on dell i8100



On Fri, Feb 13, 2004 at 04:42:46PM -0200, Alexandre Oliva wrote:
 
> > While debugging the problem, I found a
> > problem in initscripts that might also help you
 
> There's yet another bug in network-functions just above that.
> modprobe -c now prints an `install eth0 /bin/true' line even though
> there is an alias.  I can't tell whether this is by design or a bug in
> modprobe, but it looks like we may have to work around this in
> network-functions.
 
> Also, modprobe 3c574_cs will return an exit status if the module
> happens to be already loaded.  Is it really appropriate to fail
> is_available() in this case?
 
> Unfortunately, even if I comment that bit out, it will still fail on
> my box.  It seems that loading 3c574_cs simply won't add eth0 to the
> ip link output.  I'm not sure how to proceed debugging this.  Anyone
> care to suggest a lead for me to follow?

I have read the bugreport you mentioned in a previous mail and tried
booting with 'acpi=off' and 'pci=noacpi'. This makes no difference
in my case.

I simply cannot get eth0 started, and 'yenta_socket' is never loaded.
After modprobing 'yenta_socket' and trying (for example)
/sbin/ifup eth0 I always get the following:

  interface 'eth0' not found
  /bin/true
  xirc2ps_cs device eth0 does not seem to be present, delaying
  initialization

and eth0 is never activated.

And "/sbin/cardctl ident" gives no info about the card, only
'no product info available'.

Alexander






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]