[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC2 test1: pcmcia problems on dell i8100



On Feb 13, 2004, Alexander Volovics <awol home nl> wrote:

> On Fri, Feb 13, 2004 at 04:42:46PM -0200, Alexandre Oliva wrote:
>> > While debugging the problem, I found a
>> > problem in initscripts that might also help you
 
>> There's yet another bug in network-functions just above that.
>> modprobe -c now prints an `install eth0 /bin/true' line even though
>> there is an alias.  I can't tell whether this is by design or a bug in
>> modprobe, but it looks like we may have to work around this in
>> network-functions.
 
>> Also, modprobe 3c574_cs will return an exit status if the module
>> happens to be already loaded.  Is it really appropriate to fail
>> is_available() in this case?
 
>> Unfortunately, even if I comment that bit out, it will still fail on
>> my box.  It seems that loading 3c574_cs simply won't add eth0 to the
>> ip link output.  I'm not sure how to proceed debugging this.  Anyone
>> care to suggest a lead for me to follow?

> I have read the bugreport you mentioned in a previous mail and tried
> booting with 'acpi=off' and 'pci=noacpi'. This makes no difference
> in my case.

Yup.  It did in FC1, but it doesn't any more.

> I simply cannot get eth0 started, and 'yenta_socket' is never loaded.

Same here.

>   interface 'eth0' not found
>   /bin/true
    ^^^^^^^^^

This patch fixes the inappropriate printing of /bin/true:

--- /etc/sysconfig/network-scripts/network-functions~	2004-01-28 04:19:41.000000000 -0200
+++ /etc/sysconfig/network-scripts/network-functions	2004-02-13 16:37:04.000000000 -0200
@@ -174,8 +174,8 @@
     LC_ALL= LANG= ip -o link | grep -q $1
     [ "$?" = "1" ] || return 0
 
-    alias=`modprobe -c | awk "/^(alias|install) $1 / { print \\$3 }"`
-    if [ -z "$alias" -o "$alias" = "off" -o "$alias" = "/bin/true" ]; then
+    alias=`modprobe -c | awk "/^(alias|install) $1 / && ! /^install $1 \/bin\/true/ { print \\$3 }"`
+    if [ -z "$alias" -o "$alias" = "off" ]; then
         return 2
     fi
     HOTPLUG=`cat /proc/sys/kernel/hotplug`

I'm still not sure the behavior is correct, though.  What if there's
are both `install´ and `alias' entries in the output of modprobe -c?
Why should install matter, and why should we actually attempt to
modprobe it afterwards?

-- 
Alexandre Oliva   Enjoy Guarana', see http://www.ic.unicamp.br/~oliva/
Happy GNU Year!                     oliva {lsd ic unicamp br, gnu.org}
Red Hat GCC Developer                 aoliva {redhat com, gcc.gnu.org}
Free Software Evangelist                Professional serial bug killer




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]