[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Serial setup hang (Re: FC2 test1: install glitches and comments)



Hello!

Ricky Ng-Adam wrote:

On Sat, Feb 14, 2004 at 01:03:04AM -0500, Ricky Ng-Adam wrote:

-on reboot after install... Kernel Stopped booting after agpgart and
Serial: 8250[...]IRQ sharing enabled lines.  Poweroff/poweron seems


Seen this, its as if any serial interrupt occuring during the serial setup
or before it hangs the box. I've not yet been able to get much further as
I've not yet found a box I have it will boot all the way on except with
the install CD


I also see similar problems with IRQ 12 sharing, then disable then hangs
and then since IRQ 12 is _really_ used by something other than the non-existant PS/2 mouse it tried to enable that hangs too.

BTW, I can reproduce systematically this problem by


powering up the laptop + restarting Linux = hang

So there seems to be something that is supposed to happen when shutting down for reboot that doesn't.

I also noticed that in the IBM BIOS under serial port there are three options:

  Disabled
  Enabled
  OS controlled [Displayed when controlled by OS]

I've tried both Disabled and Enabled (3F8 IRQ4) but both result in the reproducible hang. I've never seen the "OS controlled" option.

Thanks,

Ricky




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]