[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC2 test1



David Finch wrote:

The install went pretty well. It detected all of my hardware. I was a little upset to not see reiserfs listed as an option in disk druid.


This a known caveat.. you have to start the install with "linux reiserfs" or something like that to enable reiser.. I had to use "linux xfs" to have the chance to use xfs... I wish these werent needed. Probably the choice to do this is that ext3 is known to be stable and very compatible , so it's the best choice... However , I wish I could simply run the installer without any parameters and then use any filesystem I choose..

Upon booting into my new install, I noticed a lot of services running at startup for things I didn't have or need, like bluetooth.


Maybe some room for development here? I always wondered why RH and FC installed the pcmcia modules when I dont have any pcmcia stuff on my computer... maybe we , as users , should try to see what is really needed on a basic system and then change it on Fedora? Experienced users can (and will) always configure the system the way they like it ... Newbies , on the other hand , will leave it as it is , with unnecessary services running , making this a security risk (even considering that the default config for many services is secure). So , less running services by default is better in this case..

After starting KDE, I noticed the red dot with the flashing exclamation point which led me to run up2date. It failed while downloading headers. Some traceback error which I forgot to write down. After several more attempts, I added some of the urls recommended in a previous post to yum.conf and it managed to download them successfully. The package list showed 0kb for every package, 375kb total, which doesn't seem right. I selected all and clicked forward, since I had nothing to lose but time. After that it froze at "Testing package set / solving inter-dependencies". I left it for 10 minutes then killed it off.



The 0kb part is related to yum repositories. Someone mentioned when FC1 was released that the headers of the rpms carry no size information , so up2date , when using yum repositories , cant show how big the packages are.. This may change soon , as work is being made on yum/up2date/apt.

Then I tried out a bunch of the screen savers that are included, and found that opengl is having zbuffer problems. Far away polygons always overlapped the near polygons. It had no such problems under Slackware 9.1. Most of the OpenGL screensavers ran as fast on Fedora as under slackware, except that the Altantis one with sharks and whales ran significantly slower on Fedora, at about 1fps even in wireframe mode in the preview box, which is strange because Slackware used some generic i810 driver for the video while Fedora detected the integrated video as the i845 that it was. The exact name according to Dell is an Intel i845GV.


Maybe this is an experimental driver? if the chip is really new , chances are that the module is still very new and still needs some work...

Relating to the problem with all the unnecessary services running at startup, I ran /usr/bin/system-config-services ("System: Services" from the KDE menu) to disable the services I didn't need. But nothing happened. It'd run for a fraction of a second and then exit quietly with no error messages I could find. I even tried running it from the console.


Filled a bugzilla report? I havent tested system-config-services yet , as I always use ntsysV to config my services , as I always have a terminal handy... But I guess I'll give it a try as soon as I reboot on FC2..

Another attempt to run up2date _appears_ to be working without serious problems, though in retrospect it was probably bad of me to click "select all". It claims most (not all) packages aren't signed with a known GPG signature, which means I have to be there while it downloads to click "yes" or the downloads stop. It'd be nice if those errors didn't stop the downloads, or if I could click "yes to all". This may take some time.



Maybe if you import the GPG keys available on the first iso will solve this. The keys are on the first cd... rpm --import path_to_key_file does the trick...

One thing I found to Fedora's benefit is that KDE 3.2 has had very few SIGSEGV errors and caused zero system crashes, which I can't say about the few days I was running Slackware 9.1 with KDE 3.1. For a test release it's been really stable albiet buggy. I haven't been able to play CD's under either distribution but I'm curious if the Dell guys may have left the cable between the cdrom and sound card unplugged, which will force me to risk voiding my warranty if that's the case.


Try to call the guys @ dell.. last time we had issues with a new computer bought from them , they were quick in fixing everything... And about the new kde and gnome.. I had only one segv and it was I tried to run evolution... but it only happened once...

Pedro Macedo





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]