[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Compiling 3COM 3c2000 Drivers in FC2

On Sunday 15 February 2004 02:29, Richard Duncan wrote:
> I've just installed FC2 (ISOs to CDs, kernel 2.6.1-1.165) and I can't
> get the 3COM 3c2000 drivers to compile.  When I try, I just get a bunch
> of gcc errors.  Everything worked fine in FC1/2.4-based kernels, so I'm
> guessing the switch to 2.6 is causing the trouble.  The Makefile looks
> for linux-2.4 for the source, so should I change this?  The linux-2.4
> alias is still sitting in the /usr/src directory, should this still be
> there?
> My specs are an Abit IS7-E with a 3COM Gigabit NIC integrated.  Again,
> the 3c2000 drivers compiled and worked fine in FC1/2.4.

Why?  The sk98lin drivers are much more recently updated and work just fine.  
I am using the sk98lin with a 3C940/3C2000 which comes on the ASUS SK8V 

The only current problem is that this NIC is not detected by the anaconda 
installer (check bugzilla) but the driver works ... at least at 100Mbps ... 
there are some comments in bugzilla about it not working at 1000Mbps.

I forget, you may need to manually add "alias eth0 sk98lin" to the 
/etc/modprobe.conf file.  one of the problems (already bugzilla'ed) is that 
the anaconda installer does not manually prompt to select an driver if it 
does not recognize the NIC.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]