[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Ati Module Build X86_64 Link Problem



I am trying to install the ATI 3.7.0 driver on my FC1 Test1 x86_64 (X version 4.3.0-42; kernel 2.4.22-1.2166) system to enable dualhead yet the rpm install gives me this error (at least here are the relevant parts):

*** Trying to install a precompiled kernel module.
*** WARNING ***
Tailored kernel module for fglrx not present in your system.
You must go to /lib/modules/fglrx/build_mod subdir
and execute './make.sh' to build a fully customed kernel module.
Afterwards go to /lib/modules/fglrx and run './make_install.sh'
in order to install the module into your kernel's module repository.
(see readme.txt for more details.)

As of now you can still run your XServer in 2D, but hardware acclerated
OpenGL will not work and 2D graphics will lack performance.

failed.

*** Found kernel module build environment, generating kernel module now.

ATI module generator V 2.0
==========================
initializing...
cleaning...
patching 'highmem.h'...
skipping patch for 'drmP.h', not needed
skipping patch for 'drm_os_linux.h', not needed
probing for VMA API version...
doing script based build for kernel 2.4.x and similar
compiling './agpgart_be.c'...
compiling './agp3.c'...
compiling './i7505-agp.c'...
compiling './nvidia-agp.c'...
compiling './firegl_public.c'...
linking of fglrx kernel module...
ld: Relocatable linking with relocations from format elf32-i386 (./libfglrx_ip.a(vm.o)) to format elf64-x86-64 (fglrx.o) is not supported
linking failed - kernel module was not generated
*** WARNING ***
Tailored kernel module for fglrx not present in your system.
You must go to /lib/modules/fglrx/build_mod subdir
and execute './make.sh' to build a fully customed kernel module.
Afterwards go to /lib/modules/fglrx and run './make_install.sh'
in order to install the module into your kernel's module repository.
(see readme.txt for more details.)


As of now you can still run your XServer in 2D, but hardware acclerated
OpenGL will not work and 2D graphics will lack performance.

failed.
*** Warning ***
The QT based control panel application did not load in any version.
 ===
ATI display drivers successfully installed
please run 'fglrxconfig' now
 ===

Yet if I run fglrxconfig and set it all up then when I try to start x it says that it cant load the fglrx module so obviously I need to build it. Obviously I somehow need to get the elf32 lib or else trick it into thinking that is it, does anyone have any suggestions? Would 2.6 kernel or bleeding edge xfree86 help me here?


Thanks for any help.
Jason Knight




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]