[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC2 test 1 dual boot



Mike Lurk wrote:
> Has anyone else had this problem. I installed FC2 test 1 on a dual
boot
> system. Windows xp was installed first and then fc2 creating the
> partitions manually, /boot, /swap, and /. This was done on a 40 gig
hard
> drive, giving 20gig to windows and the rest for fc2. I had a second
hard
> drive with all my important stuff on a 10gig hard drive which I mount
> after booting to fc2. When I try to boot to Windows I get;
> 
> Other
>         rootnoverify (hd0,0)
>         chainloader +1
> 
> on the screen and thats it. When I check the partitions with linux
fdisk
> it all looks normal;
> 
>   Device Boot      Start         End      Blocks   Id  System
> /dev/hda1   *           1       40641    20482843+   c  W95 FAT32
(LBA)
> /dev/hda2           40642       40844      102312   83  Linux
> /dev/hda3           40845       77332    18389952   83  Linux
> /dev/hda4           77333       77536      102816    f  W95 Ext'd
(LBA)
> /dev/hda5           77333       77535      102280+  82  Linux swap
> 
> but then when i try dos's fdisk i get
> 
> 1. non dos partition
> 2. non dos partition
> 3. extended partition
> 4. fat32
> 
> and this is in my grub.conf
> 
> # grub.conf generated by anaconda
> #
> # Note that you do not have to rerun grub after making changes to this
> file
> # NOTICE:  You have a /boot partition.  This means that
> #          all kernel and initrd paths are relative to /boot/, eg.
> #          root (hd0,1)
> #          kernel /vmlinuz-version ro root=/dev/hda3
> #          initrd /initrd-version.img
> #boot=/dev/hda
> default=0
> timeout=10
> splashimage=(hd0,1)/grub/splash.xpm.gz
> title Fedora Core (2.6.1-1.65)
>         root (hd0,1)
>         kernel /vmlinuz-2.6.1-1.65 ro root=LABEL=/ rhgb
>         initrd /initrd-2.6.1-1.65.img
> title Other
>         rootnoverify (hd0,0)
>         chainloader +1

With dual hard disks. I had to use the excerpt from grub to boot XP

  title Windows NT / Windows 95 boot menu
      root        (hd0,0)
      makeactive
      chainloader +1

The rootnoverify excerpt didn't work for the dual hard disks.

> 
> I see a problem here with the differences in linux's version of fdisk
> and dos's, the way in which the partitions are setup. I've tried
> installing the dual boot 3 times and all 3 times it's been the same
> outcome.
> 
> I filed a bug report in Bugzilla and it is bug 115980
> 
> I just thought of something..... it couldn't make a difference...it
> shouldn't... jumper settings on the hard drives set to cable
> select??????
> 

Master and slave settings work for me, better than cable select. This 
might cause a problem also.

> Checking this out.......later
> 
> Mike
> 
> 

Jim

The only thing is that it worked in FC1. I didn't think of it before
because of that. The only thing that I can think of that would cause
that type of problem is in the drive geometry when using cable select
and the normal master and slave jumper settings. On rare occation it has
given me a problem with OS's but not with Linux. It was only with the
older bios's that have a problem. This is a new mobo Asus A7N8X-E and it
shouldn't give me any type of problem. But you know the old adage, if it
can it will, so what I am doing is starting all over again and using the
normal master, slave jumper settings to see if that makes a difference.

Later

Mike




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]