[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

bad obsoletes in compat-db causes yum grief?



with 'yum -d 8 upgrade' I get the following error:

---------
localhdrpath= /var/cache/yum/fedora-dev/headers/e2fsprogs-0-1.35-6.1.i386.hdr for e2fsprogs i386
localhdrpath= /var/cache/yum/fedora-dev/headers/compat-db-0-4.1.25-2.i386.hdr for compat-db i386
versioned obsolete
db4, 2, 0, 4.2, None
Traceback (most recent call last):
  File "/usr/bin/yum", line 30, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum/yummain.py", line 249, in main
    obsoleting, obsoleted = clientStuff.returnObsoletes(HeaderInfo, rpmDBInfo, nulist)
  File "/usr/share/yum/clientStuff.py", line 286, in returnObsoletes
    rc = rpmUtils.compareEVR((e1, v1, r1), (obe, obv, obr))
  File "/usr/share/yum/rpmUtils.py", line 120, in compareEVR
    rc = rpm.labelCompare((e1, v1, r1), (e2, v2, r2))
rpm.error: Invalid version or release - possibly None
----------
'yum update' doesn't give any errors. This is from duke mirror for rawhide.

Perhaps there is some bad obsoletes info in compat-db rpm?

Satish




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]