[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Nforce sound driver not working



I have an onboard Via Envy 24PT sound chip (on a Chaintech ZNF3-150) and I am using the NVIDIA_nforce-1.0-0269 <http://download.nvidia.com/XFree86/nforce/1.0-0269/NVIDIA_nforce-1.0-0269.tar.gz> driver and when I try modprobe nvaudio I get

/lib/modules/2.4.22-1.2174.nptl/kernel/drivers/sound/nvaudio.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.22-1.2174.nptl/kernel/drivers/sound/nvaudio.o: insmod /lib/modules/2.4.22-1.2174.nptl/kernel/drivers/sound/nvaudio.o failed
/lib/modules/2.4.22-1.2174.nptl/kernel/drivers/sound/nvaudio.o: insmod nvaudio failed


so I tried an insmod audio to see what the problem was and it gave me this-

Using /lib/modules/2.4.22-1.2166.nptl/kernel/drivers/sound/nvaudio.o/lib/modules/2.4.22-1.2166.nptl/kernel/drivers/sound/nvaudio.o: /lib/modules/2.4.22-1.2166.nptl/kernel/drivers/sound/nvaudio.o: unresolved symbol ac97_probe_codec_Redf32a8e
/lib/modules/2.4.22-1.2166.nptl/kernel/drivers/sound/nvaudio.o: /lib/modules/2.4.22-1.2166.nptl/kernel/drivers/sound/nvaudio.o: unresolved symbol ac97_set_dac_rate_R99dd7def
/lib/modules/2.4.22-1.2166.nptl/kernel/drivers/sound/nvaudio.o: /lib/modules/2.4.22-1.2166.nptl/kernel/drivers/sound/nvaudio.o: unresolved symbol ac97_set_adc_rate_R2f0e0a59


so I did an insmod ac97_codec and it worked so I tried the insmod again and got this-

Using /lib/modules/2.4.22-1.2174.nptl/kernel/drivers/sound/nvaudio.o
/lib/modules/2.4.22-1.2174.nptl/kernel/drivers/sound/nvaudio.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg


dmesg only shows

Nvidia Audio, 22:45:39 Feb 20 2004 version 9999
Nvaudio: in Funcction Nvaudio_init_module


Any ideas? Thx
<http://download.nvidia.com/XFree86/nforce/1.0-0269/NVIDIA_nforce-1.0-0269.tar.gz>



-- Jason Knight Fedora Core 1 Test 1 *x86_64*




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]