[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: /sbin not in path



On Sun, 22 Feb 2004, Sean Earp wrote:

>I  did not see an answer to this in the archives, so if it is a stupid 
>question, I apologize in advance.
>
>I just did a clean install of FC2 Test 1, formatting my drive in 
>advance.  I chose all the default options during the install.  Once I 
>booted up to the desktop, I did not have any network connectivity 
>(although the internet/network worked fine with FC1).  I popped open a 
>terminal window and typed
>
>ifconfig
>
>To check if I was obtaining an IP address.  I received a message that 
>the command "ifconfig" could not be found.   After doing some 
>troubleshooting, I found that       /sbin      was not part of my 
>default path.  If I manually move to the /sbin directory and run 
>./ifconfig, it works fine.  If export the /sbin directory to my path, 
>it works fine.
>
>My question is...      Is the omission of the /sbin directory in the 
>default path an error, or is something messed up with my installation?  
>  As far as I recall, ifconfig worked just fine in FC1

It's not an error.  /sbin and /usr/sbin have never been in the 
default user path.  They are only in root's path by default, and 
only if you are using a root login shell.  This means if you use 
"su" to switch to root from a user account, you won't have these 
directories in your path either.  Instead you need to use "su -" 
to initiate a login shell.

It has always been this way.


-- 
Mike A. Harris     ftp://people.redhat.com/mharris
OS Systems Engineer - XFree86 maintainer - Red Hat




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]