[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: /sbin not in path



Sean Earp <smearp mac com> writes:

> Hello all-
>
> I  did not see an answer to this in the archives, so if it is a stupid
> question, I apologize in advance.
>
> I just did a clean install of FC2 Test 1, formatting my drive in
> advance.  I chose all the default options during the install.  Once I
> booted up to the desktop, I did not have any network connectivity
> (although the internet/network worked fine with FC1).  I popped open a
> terminal window and typed
>
> ifconfig
>
> To check if I was obtaining an IP address.  I received a message that
> the command "ifconfig" could not be found.   After doing some
> troubleshooting, I found that       /sbin      was not part of my
> default path.  If I manually move to the /sbin directory and run
> ./ifconfig, it works fine.  If export the /sbin directory to my path,
> it works fine.
>
> My question is...      Is the omission of the /sbin directory in the
> default path an error, or is something messed up with my installation?
> As far as I recall, ifconfig worked just fine in FC1
>
> Any information would be much appreciated.   Thanks a million,

Well, I can't speak for fedora policy but if you were running ifconfig
as a user not root, that is supposed to happen at least by default.

That is, sbin is not included in user's path on purpose in many
distros.   Sbin contains many programs that can be dangerous to the os
health in the wrong hands.

Just put it in your path in .bash_profile.




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]