[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Multiple Installed Packeages



BOB: 
i ran into the same problem last night in a fedora core1, with
apt/synaptic and many unstable and testing repositories, and a very
unlucky power failure in the middle of a massive rpm upgrade.

rpm throws a message like this for each package(doing this from my
recent brain memory)
ERROR: package XXXXXX exists bla bla bla s


HOW I FIXED:
i ran apt-get update
on the output gaves a list of duplicate pakages...
(DO THIS ONCE, NEVER TWICE)
rpm -e namepack1 namepack2 namepack3 .... namelastpack
it should give a kind of message that says something like: error:
package blabal ...  (just one line of output per package)

if the operation ends with no dependencies missing... just the error
line per package...

do the following :
apt-get install namepack1 namepack2 namepack3 .... namelastpack


the apt-get output should say something like : the blabla package is the
newest. and so on... and if you break a package on the rpm -e part.. the
apt-get should re-installed and with no errors..

if the rpm -e gaves any error diferent than the error package exists ..
like a dependency or scriptlet failed the rpm -e operation didn't do
anything . so remove the conflicting packages from the rpm -e command
line. and do more rpm -e / apt-get install package for each package...

this is how i fixed...

at the end rebuild the rpm db with rpm --rebuilddb
 ta-ra! 

On Wed, 2004-02-25 at 10:07, Bob Chiodini wrote:
> Good Morning,
> 
> I've had several up2date and yum hiccups lately and ran out of disk
> space.  Delving into where the space went, I found that I have two
> versions of quite a few packages installed.  For example, rpm -qa | grep
> cyrus | sort returns the following:
> 
> cyrus-imapd-2.2.3-2
> cyrus-imapd-devel-2.2.3-2
> cyrus-imapd-devel-2.2.3-4
> cyrus-imapd-murder-2.2.3-2
> cyrus-imapd-murder-2.2.3-4
> cyrus-imapd-nntp-2.2.3-2
> cyrus-imapd-nntp-2.2.3-4
> cyrus-imapd-utils-2.2.3-2
> cyrus-imapd-utils-2.2.3-4
> cyrus-sasl-2.1.17-1
> cyrus-sasl-devel-2.1.17-1
> cyrus-sasl-gssapi-2.1.17-1
> cyrus-sasl-md5-2.1.17-1
> cyrus-sasl-plain-2.1.17-1
> 
> yum update complains that cyrus-imapd-2.2.3-2 is not available, when
> trying to update the other cyrus-imapd-xxxx packages.
> 
> Is there a way to clean this up?  I tried rpm --rebuilddb incase the
> database was toast, but no luck.
> 
> Bob...
-- 
Christian B. Ellsworth Capo (k dicec cl)
Linux Chief Engineer
RedHat Certified Engineer (RHCE)


DICEC Ltd.
Sanchez Fontecillas 966b, Las Condes, Santiago, Chile.
Phone (56 2) 2633340
Fax (56 2) 2071820
Movil (56 9) 4195632

Attachment: signature.asc
Description: This is a digitally signed message part


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]