[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Mouse issues with updated 2.6.3 kernel via up2date and more

On Sat, 2004-02-21 at 23:13 -0500, Jim Cornette wrote:

> Aaron Kincer wrote:
> > I too get the mouse problems with the start of the X server with the updated
> > kernel.  I have tried  the fix offered here of changing the psaux to mouse
> > in the config file but that doesn't work for me. 
>   Tried quite a few things
> > there but they were all very uneducated guesses.
> > 
> Try changing the first of the two headings to point to "/dev/input/mice" 
> also. Either that, or edit the symlink for "/dev/mouse" to point to 
> "/dev/input/mice"

Have been moving so I haven't been reading the list or doing updates for
a several days.  Just updated from kernel-2.6.2-1.81 to kernel-2.6.3-
1.106 yesterday (kernel-2.6.3-1.109 today) and ran into problems with X
not starting that seem to go back to about Feb. 17, with the "kernel-
2.6.2-1.85 borked X" and similar threads.  

After catching up on the list, seems the symlink should be:

[root tabb1 root]# ll /dev/mouse
lrwxrwxrwx  1 root root 10 Feb 26 22:39 /dev/mouse -> input/mice

My /etc/X11/XF86Config was changed accordingly:

from:       Option      "Device" "/dev/psaux"
to:         Option      "Device" "/dev/mouse"

Similarly for gpm, /etc/sysconfig/mouse changes are:

from: DEVICE=/dev/psaux
to:   DEVICE=/dev/mouse

I also had to fix the MOUSETYPE to get gpm to work for my Logitech
MouseMan wheel mouse:

from: MOUSETYPE="ps/2"
to:   MOUSETYPE="imps2"

> > Also, I have an HP psc 750xi scanner/copier/printer all in one.  Printing
> > works fine (just don't try to print in GIMP).  But the scanner doesn't work.
> I just checked out my scanner and it does not work either. It worked 
> during tests for the 2.4 kernel and Fedora 1. I rarely use it, but it is 
>   not detected now. I have a "Scanjet 2100C" flatbed scanner that "just 
> worked", without any configuration, in FC1 with the 2.4 kernel.

Just checked my infrequently used Epson Perfection 1650 scanner that has
worked (with more to less effort) from RH7.3 through FC1.  xsane sees
only my Hauppauge TV card, not the scanner, although ...

[root tabb1 root]# sane-find-scanner

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x04b8 [EPSON], product=0x0110 [EPSON Scanner]) at libusb:001:003
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Scanners connected to the parallel port or other proprietary ports can't be
  # detected by this program.

[root tabb1 root]# scanimage -L
device `v4l:/dev/video0' is a Noname BT878 video (Hauppauge (bt878)) virtual device


[root tabb1 root]# lsusb
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 003: ID 04b8:0110 Seiko Epson Corp. Perfection 1650
Bus 001 Device 002: ID 0409:0058 NEC Corp. HighSpeed Hub
Bus 001 Device 001: ID 0000:0000

Reading the sane-epson backend and sane-usb man pages has not given any
enlightenment.  Haven't done a google, nor searched outside this list
yet.  Anyone managed to scan with 2.6.x?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]