[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Really strange problem with the 2.6.x kernels



Hi,
/dev/psaux doesn't seem to work on 2.6 kernels. I had the same problem. I changed all references to /dev/psaux to /dev/input/mice in my XF86Config file, and all was well. I've also seen people suggest symlinking /dev/psaux to point to /dev/input/mice. I'm not sure which is the better solution - they end up at the same place, it seems, although I'm sure we could have deep philosophical arguments about the correct way to do it.

Blaise

On Feb 27, 2004, at 4:56 PM, Paul wrote:

Hi,

Up to last night, I was happily running a version of the 2.6.2 kernel
I'd compiled myself. It worked well.

I attempted to run the 2.6.3-109 kernel. X wouldn't fire up as /dev/
psaux couldn't be found. Damn, says I, and tried to go back to the 2.6.2
kernel. For some reason, the keyboard locked immediately after selecting
the 2.6.2 kernel from grub. X started fine, but with no mouse or
keyboard.

Reset and moved back to the 2.4.24 kernels and all is well again.

Any ideas on what could be causing this?

TTFN

Paul

--
"Logic, my dear Zoe, is merely the ability to be wrong with authority"
Dr Who

------------------------------------------------------
Blaise Frederick
McLean Hospital Brain Imaging Center
115 Mill St.
Belmont, MA 02478
Ph: (617)-855-3708
FAX: (617)-855-2770


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]