[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

gcc for kernel different than current gcc



Hi,

Currently in rawhide the gcc is gcc-3.4 while the kernel (kernel-2.6.6-1.435)
was compiled with gcc-3.3. As a consequnce, when I try to insmod a module
I build myself (ADSL modem), I get in dmesg:

eagle_usb: version magic '2.6.6-1.435 686 REGPARM 4KSTACKS gcc-3.4' should be '2.6.6-1.435 686 REGPARM 4KSTACKS gcc-3.3'

and a insmod -v leads to 'Invalid module format'.

It maybe a good think to provide (keep) 'automatically' a compatible gcc, 
just like how different kernels may coexist (I use yum). Or there could be 
another solution...

Of course this is not a serious issue as it should disappear soon (and it
seems to be in compat-gcc).

Pat



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]