[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Fedora Core 2 Test 3 on an IBM Thinkpad 600x

Quick impressions of installing and running Fedora Core 2 Test 3 (FC2t3) on an IBM Thinkpad 600x (2645-5FU)

Hardware: Pentium III 650MHz (SpeedStep reduces speed to 500MHz when operating on batteries)
Graphics: Neomagic 256ZX
Display: 13.3 TFT

Installation of FC2t3 went fairly smoothly. For some reason, it complained that my partition table (generated by a previous redhat 9 installation which I wiped out in the course of installing FC2t3) was inconsistent and that I would have problems booting. Recommended that I make a bootdisk. However, I was never again prompted to make a bootdisk later on in the installation. (Also, I read somewhere that the 2.6 kernel is too large for a boot floppy so perhaps this should be fixed.)

I picked a 1024x768 generic LCD display but for some reason, the display configurator chose a 800x600 24 bit resolution. Perhaps it detected 2.5MB of video memory and automatically picked the 800x600 resolution? Redhat 9 allowed me to run 1024x768 at 24bpp.

When I installed FC2t3, I did not have any network card in the machine. (More on this later.)

Since I prefer KDE to GNOME, after installation, I logged in to my KDE desktop. FC2t3 had no trouble with my previous KDE 3.2 settings which were already present on my /home partition with one exception. Autorun started running immediately and tried to find a non-existent CD.

When I tried to add/remove packages using the GUI, I ran into a problem. KDE (or is it the installer?) mounted the FC2t3 CD 1 and brought up the contents in a Konqueror filemanager window which is very distracting since I was in the middle of choosing packages to install. Later when the add/remove package GUI asked me to remove CD1 and insert CD2, I could not eject CD1 since it was mounted. I had to unmount the CD, then eject it and insert CD2. This should be fixed.

Since FC2t3 is GNOME centric, I expected KDE to be fairly broken and it was. There was no JuK (which I was looking forward to). Perhaps this is because MP3 support is disabled?

I rebooted and inserted a CISCO Aironet-based 80211b card. While the card was recognized, I could not get network connectivity. However, I did not try hard enough. I rebooted once again and inserted a Compaq WL110 card (orinoco-cs driver). This was also recognized and this time I didn't have to do anything since the network was set up automagically after booting. I keep seeing Connected, Disconnected toggling messages when I do dmesg but so far it seems to be working all right. Previously (when the machine was running redhat 9) the orinoco-cs 0.13e driver would freeze the machine solid but this seems to be fixed. Downloaded a 75MB file without any problems or lockups.

When I rebooted for the second time, it said that it had to do some recovery of my / ext3 partition and later on mentioned that it had cleaned up some inodes. WTF is that? AFAIK, I had cleanly rebooted. This should not have happened.

up2date does not work. Could not connect to the (somewhat local) duke mirror. Perhaps yum.conf has to be fixed. When I ran yum update from the command line, it took a while but updated everything. Got tons of selinux error messages.

Tried to install apt-0.5 from the FC testing directory on apt.freshrpms.net. Complained about a missing signature and generated tons of selinux-based errors which still show up when I do dmesg. I then disabled selinux in the security settings.

When FC2 boots up, it brings up a console localhost login prompt for a few seconds and just when I try to type in my name, the display manager comes up. Somewhat disconcerting.

Have not checked suspend/resume functions.

Unfortunately, since I prefer KDE and want my multimeda to work out of the box, I think I'll try SUSE 9.1 when it comes out. FC2 is not bad but seems too developer- and GNOME-centric for me.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]