[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Scanner Frustration

Jim Cornette wrote:
Gerry Tool wrote:

I have been trying to get my Epson 1240U scanner (which works in everything prior to FC2Tx) to work, following bugzilla report 121511. It is not clear exactly what needs to be done that seems to work for some others. Could someone post a complete step-by-step process to this list that details how to get usb scanners to work in FC2T3?

Having a working scanner is a requirement for me to use FC2 when it is released.


Gerry Tool

From the "Scanner Access Now Easy" website.

With Linux 2.4.* you could either use the kernel scanner module or libusb to access USB scanners. In Linux 2.6.4 the kernel scanner module was removed.
Therefore with this and later kernels libusb must be used.

While SANE automatically uses libusb when the library and its header file were present during the build of sane-backends, setting permissions will require *some attention.*

The device files used by libusb are located in /proc/bus/usb/
(e.g. /proc/bus/usb/001/003). The exact file name can be found out by running sane-find-scanner which would print "libusb:001:003" in this case. While setting permissions with e.g. "chmod a+rw /proc/bus/usb/001/003" seems to work, this change is not permanent. The permissions will be reset when the scanner is replugged or Linux is rebooted.

One solution to set permissions on-the-fly are the Linux hot-plug tools that should come with any current distribution. SANE itsself comes with a hotplug script and related documentaion in the tools/hotplug/ directory. Please refer to the README in that directory for the details.

My comment:
Basically, permissions are not setup correctly with libusb. You need to set the permission of whatever device position that sane-find-scanner states. This has to run as root. The file permissions will not recognize the scanner as a normal user.

Then you have to do what was stated above. I just tried to open my scanner without changing the file permissions and it did not work. I then ran the below command as root.

chmod a+rw /proc/bus/usb/001/004

(001 is for the hub. 004 is the port on the hub, for my scanner. This gives the scanner file permissions rw for owner, group and others)

 ls -la /proc/bus/usb/001/004
-rw-rw-rw-  1 root root 57 May  3 18:13 /proc/bus/usb/001/004

I then tried the scanner as a regular user. It worked after running the command.

There is a new version that I just notified in the bug report mentioned above. Maybe the changes made will make scanner access easy again.

Hope this is clearer.

Thanks for your reply, Jim. I changed the permissions, but that did not solve the problem. Another reply from Mike Styne held the other key. I needed to change the /etc/sane.d/epson.conf file in a different way from all previous releases. Thanks to the two of you, I now have a working scanner. I did verify that changing the permissions back broke it again. I hope the FC2 release will have this problem solved so that users don't have to muck around with either the permissions or the details of the xxxx.conf files.

Gerry Tool

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]