[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Use of labels in grub.conf

On Wed, 2004-05-05 at 20:12, Gene Heskett wrote:
> On Wednesday 05 May 2004 21:17, thisismyspamdump rogers com wrote:
> >I ran into the same issue when recompiling 2.6.5-1.349 earlier
> > today. I deleted root=LABEL=/ rhgb altogether. I found the fix
> > somewhere on google, not at home so I can't say where, but it was a
> > support forum for a different distro, the issue there was with a
> > 2.6.5 kernel update as well.
> >
> >Joe
> Yeah, I wondered about that rhgb in there too, particularly when I 
> cd'd to the Documentation dir to read kernel-parameters.txt and found 
> absolutely no mention of that option.  I can't recall ATM if I killed 
> that or not.  I certainly took out the quiet, I wanna see whats 
> screwing up!
> >
> >> From: Gene Heskett <gene heskett verizon net>
> >> Date: 2004/05/05 Wed PM 08:59:09 EDT
> >> To: For testers of Fedora Core development releases
> >> <fedora-test-list redhat com> Subject: Use of labels in grub.conf
> >>
> >> Greetings;
> >>
> >> This is a resend, from my home account, no idea how it was sent
> >> thru the work account, which of course bounced...
> >>
> >> My old 233mhz P-II needs all the help it can get, so I was
> >> compiling a stripped down kernel.  But I couldn't boot to it (no
> >> initrd, just modules) using the root=LABEL=/ in the grub command
> >> line.
> >>
> >> Fooled with it for several hours, then decided to use
> >> root=/dev/hda8 (home of the / partition) instead.  Worked first
> >> time.
> >>
> >> What is it that allows the default FC2T3 kernel to use labels
> >> while its booting, but when I duplicate the grub entry but with
> >> the newer vmlinuz name, I have to use root=/dev/hda8?
> >>
> >> Or is this a real bug?
> >>
> >> --
> >> Cheers, gene
> >>
> >>
> >>
> >> --
> >> fedora-test-list mailing list
> >> fedora-test-list redhat com
> >> To unsubscribe:
> >> http://www.redhat.com/mailman/listinfo/fedora-test-list
> >
> >1
> -- 
> Cheers, Gene
> "There are four boxes to be used in defense of liberty:
>  soap, ballot, jury, and ammo. Please use in that order."
> -Ed Howdershelt (Author)
> 99.22% setiathome rank, not too shabby for a WV hillbilly
> Yahoo.com attorneys please note, additions to this message
> by Gene Heskett are:
> Copyright 2004 by Maurice Eugene Heskett, all rights reserved.

If I recall correctly (and you have to wonder about that), the labels
went in before hotplug/udev came along so that there would be some
permanance with respect to devices and mount points.  As I seem to
recall, /etc/fstab had to have the labels included as well (and maybe
something else).  I don't use labels for my own kernel builds, just give
it the root partition device name.  As for the ramdisk image, I usually
build it (and have a little prompt/reminder in my kernel build script
for me to do it): 

echo "Remember to edit /etc/lilo.conf for this kernel"
echo "And then run /sbin/lilo and reboot (init 6)"
echo "and make a boot initrd file by running"
echo "/sbin/mkinitrd -v /boot/initrd-<your-kernel>.img <your kernel>"
# mv /boot/System.map /boot/System.map.old
# cp -f System.map /boot
rm /boot/initrd-$BUILD.img
/sbin/mkinitrd -v /boot/initrd-$BUILD.img $BUILD
echo "Ramdisk image pre-built.  Check /boot and modify

(some parts of my build script are just a wee bit out of date).

There isn't a lot of information on RedHat Graphical Boot (rhgb), but if
you want to see what is going on, either "show details" or ctrl-F1 will
get you there.  I know before I switched to reiserfs for the boot
partition, e2fsck could run for a while (unclean shutdown, file system
sticky bit not set) in FC1 (and one could enjoy their time watching it
run:)  If you get to ctrl-F1 and want to go back to the graphical boot,
use ctrl-F8 (one higher than X-windows).

Have a good one,

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]