[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

upgrade from FC1 to FC2 test 3 seems to leave things unfinished

Having successfully installed FC2 test 3 on an old computer and watched it work, I decided to upgrade an FC1 machine to FC2 test 3.

All apparently progressed normally until I rebooted, and was presented with the grub splash screen...but no Fedora choice! I booted from Knoppix and looked at /boot, and found the following:

-- Sure enough, /boot/grub/grub.conf had all Linux choices deleted from it.
-- In /boot, vmlinuz was still linked to the FC1 version, ditto for System.map.
-- Also in /boot, there was no initrd for FC2!

Over in /etc, I saw a modules.conf~ and a modules.conf.pre26, but no modules.conf.

I tried upgrading it to itself, but that did not help.

Fortunately, I'd backed up immediately before starting the upgrade, so I bit the bullet, chose "install," which worked fine, and restored files from the backup.

James Jones

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]