[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: HP Scanner Difficulties

jim tate wrote:
Tim Waugh wrote:

On Wed, May 05, 2004 at 08:42:51PM -0500, Jason Knight wrote:

For PSC devices you should install libsane-hpoj -- my multifunction
scanner is working very well here and has been since FC1.

[root localhost root]# rpm -q libsane-hpoj libsane-hpoj-0.91-6

Is there some kind of config file I need to run first though? As I am not running any hpoj files or binaries, (except the one started by Kudzu). The scanner was auto found by kudzu as below snip from /etc/sysconfig/hwconf shows:

There's no automatic detection for hpoj devices yet I'm afraid.  You
need to run 'service hpoj setup' as root first.  Access permissions
are handled completely differently to normal USB devices.

When setting the printer up make sure to use PTAL rather than USB.


I have a HP4200C and finally I understand that is supposed to work with new
If i run scanimage -L , I get a vendor=0x4b8, product=0x0602, chip-GT-6816?) at libusb:003:004.
What do I need to do to get it to install properly?

Jim Tate

Have you tried to run the below command in a root terminal?

chmod 006 /proc/bus/usb/003/004

This should set the permission of the scanner to world readable and writable. The scanner should then be recognized when xsane is launched from the launcher.

I have an HP scanner also and do not have to edit any config file.

As an alternative to the changing the permissions of the file as root, you could install the test sane-backend package that was discussed earlier on the list. You have to unplug the scanner from the USB port to get it to hotplug and change the file permissions to the permissions needed for xsane and friends to be able to recognize and access the scanner.

Hopefully this helps explain how to change the permission for the scanner and get it to work.

As a note, the file permissions change each time that you reboot you computer, if the scanner is plugged in. The file (scanner access point) is set to read-write for root (owner) and read for group and for others. Only having read permission on the file is not good enough to get the scanner working.


Caution: breathing may be hazardous to your health.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]