[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: unable to disable selinux

Thanks to everyone for the quick replies. Unfortunately, none of the three helped.

1) Installing the "policy" rpm just gives me more warnings. If selinux is disabled, it shouldn't be checking for /etc/security/selinux/anything right?

2) Upgraded to kernel 2.6.5-1.351 and the behavior is unchanged.

3) Removed the /selinux directory and still no difference.

Any other ideas?

Gerry Tool wrote:
Rich Ibbotson wrote:

Hi all,

Sorry if this is covered somewhere else, I haven't been able to find the answer in the archives.

I've just upgraded from RH8.0 to FC2 test3 and I'm trying to disable selinux until I get other problems sorted out. I've tried passing selinux=0 on the kernel line in grub, and I've also tried creating a file /etc/sysconfig/selinux with the contents SELINUX=disabled.

Either way, whenever I issue a command like:
rpm -V x11-org

I see the error message:
/etc/security/selinux/file_contexts: No such file or directory

so I think selinux is enabled. /usr/bin/selinuxenabled exits with a return value of 1.

What do I need to do to really disable selinux? I'm running kernel 2.6.5-1.327.


try updating to the latest kernel (2.6.5-1.351 I believe.)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]