[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Unable to boot on WinXP after Fedora Core 2 test3 install

Gerry Tool wrote:
Jim Cornette wrote:

Marco Bambini wrote:

I have a laptop (Acer Aspire 1300 with a 20GB HD) with Windows XP in the first partition (15GB) and Fedora Core 2 test1 in the second one (with GRUB for the dual boot and it always works fine). I have decided to install Fedora Core 2 test3 (with the erase linux partition option) and the installation works fine.

But when I try to boot on my WindowsXP partition (with Grub) nothing happens...
I am now UNABLE to boot into my WindowsXP partiotion...
I have read that others have the same problem after the Fedora install ... but I haven't found any solution that works for me.

Anyone can help me?

#fdisk -l Disk /dev/hda: 20.0 GB, 20003880960 bytes 16 heads, 63 sectors/track, 38760 cylinders Units = cylinders of 1008 * 512 = 516096 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1       26550    13381168+   7  HPFS/NTFS
/dev/hda2           26551       26753      102312   83  Linux
/dev/hda3           26754       37785     5560128   83  Linux
/dev/hda4           37786       38760      491400    f  W95 Ext'd (LBA)
/dev/hda5           37786       38760      491368+  82  Linux swap

#cat /etc/grub.conf
# grub.conf generated by anaconda
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,1)
# kernel /vmlinuz-version ro root=/dev/hda3
# initrd /initrd-version.img
title Fedora Core (2.6.5-1.327)
root (hd0,1)
kernel /vmlinuz-2.6.5-1.327 ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.5-1.327.img
title WindowsXP
rootnoverify (hd0,0)
chainloader +1

I really need your help...
Thanks a lot.

Marco Bambini

I had a problem during FC1 where XP would not boot. I see that the partition is active already from the fdisk output.

I ended up putting the below into grub.conf and it worked. This was the entry from the configuration section in "info grub".
I only see a difference between the two entries with root instead of rootnoverify and the makeactive entry.

    # For booting Windows NT or Windows95
     title Windows NT / Windows 95 boot menu
     root        (hd0,0)
     chainloader +1



Yes, I had tried this to no avail during one of my failures of XP to boot.

Gerry Tool

I haven't read the info for FC2 versions of grub. Is there any changes in the documentation regarding changes to the way non-linux OSes are configured. I pulled the info from FC1's version of grub.

When the above entry worked for me, FC was on a slave disk and XP was on the primary disk. Before changing the entry from the default entry to the one from grub's documentation, XP only booted to a black screen and did not load.

Do you think that the problem might be that fdisk (linux) set up the information in the partition table differently than XP is used to?

I wonder what booting into level 1 and changing the hda4 entry to a primary partition, instead of an extended partition, changing hda4 to a linux swap partition and eliminating hda5 would have any positive effect? (Thinking that XP might have different meanings for info in boot.ini with the extended partition. (container for linux swap).

Sorry no help for this particular booting XP problem. It looks like putting in the installation CD for XP and going to the console repair mode and running fixboot and fixmbr might be the only solution. It would show what XP (nt) thinks the partition name should be.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]