[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

First impressions FC2 final

I downloaded FC2 final today thanks to Bittorrent/Azureus and a thousand
seeds saturating my cable modem connection at 450KB/s.  I'm actually
writing this from my brand new Fedora Core install that is replacing my
Mandrake Linux 10 Community.

On the install, nothing much to say except that everything works as
expected. I chose the default workstation install to see what it looked
like. The graphic designers did an excellent job in my opinion. The
install icons and the first boot configuration user interface are very slick and professionnal.

The first hitch I encountered was after that: I tried logging in but my
desktop refused to come up. I was pleasantly surprised that this
problematic situation was detected and that I was offered a chance to
have a look inside the .xsession-errors. The problem itself was rather simple: since I had kept my old Mandrake /home partition and the same username, the user and group ownership information was incorrect. I feel this could have been detected by the firstboot program and the permissions correctly changed. To solve this, I instead had to switch to the console and chown my home directory.

Once the desktop came up, I found the background again quite attractive. However, no sound... It seems that my old SoundBlaster AWE32... I wasn't that surprised by it, it seems that my trusty sound card (that works in W2K without any hitch) is not recognized anymore by new kernels.

I still find the panel oversized, twice the size of the W2K
panel, but that's the way it is in the Linux world (KDE also likes to steal screen real estate).. Navigating the menus, I found them relatively well organized althought I think there is just too many items in some, such as Games. I feel the UI rule of thumb of 5-7 items per level in menus should be respected, especially when some of the games provided are substandard or require a not-very-often properly configured 3d card (TuxRacer).

My next step was to launch the browser. As expected, my connection
didn't work - I had noticed that the install program had decided to choose eth0 (a NIC that has no cable connected to it) instead of the more suitable eth1 (connected to my W2K bunch that uses ICS to share the Internet connection) as active per default.

I went in Network to switch both and tell it to use DHCP eth1 instead of
eth0.  I restarted and tried again but no luck - it couldn't resolve
hostname.  After messing around, I finally found that I needed to
activate the checkbox "Automatically obtain DNS Information from
provider". I not sure why this wasn't done automatically, but at least
now I was able to get on the net.

My next step was to try to configure my network printer, an Okidata OL400e connected to again my W2K box. This is quite easy to do in Windows, but in this case FC2 found out that it didn't have the samba-client... I was a bit frustrated at this - this being a "Workstation" install, the kind we can expect in a corporate environment with probably lots of shared printers and file folders, this is required.

Installing this was relatively easy.  The Add/Remove Applications is
nice enough and I decided to also add the System Applications.  I also
looked for a program to take screenshots, but was unable to find any...

CD1, CD2 went ok but when it got to nmap on CD3, the install program was
now telling me that it was "Unable to access disk".  A trip to the
console showed that the CD-ROM was indeed there and that the nmap rpm
was there too.  It also showed strange errors:

UDF-fs DEBUG fs/udf/lowlevel.c:57:udf_get_last_session: XA disk: no,
UDF-fs DEBUG fs/udf/super.c:1552:udf_fill_super: Multi-session=0
UDF-fs DEBUG fs/udf/super.c:540:udf_vrs: Starting at sector 16 (2048
byte sectors)
UDF-fs DEBUG fs/udf/super.c:567:udf_vrs: ISO9660 Primary Volume
Descriptor found
UDF-fs DEBUG fs/udf/super.c:570:udf_vrs: ISO9660 Supplementary Volume
Descriptor found
UDF-fs DEBUG fs/udf/super.c:576:udf_vrs: ISO9660 Volume Descriptor Set
Terminator found

After a few tries, including putting it in my second CD-ROM (alas, the
install program doesn't look there, I aborted. On reinstalling
specifically nmap, I was able to get it thru. I don't really understand why it didn't work in the first run at it...

Back to setting up my printer:  I had to Specify the private IP of my
W2K box and the name (couldn't browse it).  I then had a limited choices
of printer drivers, none immediatly fitting what I should choose for my
Okidata, so I picked up Postscript driver and decided to look at this later.

How about mounting a Windows share?  I went to the desktop, selected My
Computer, Network, Windows Share... Nothing.  Not surprising, I haven't
found any distros that made it easy.  So another trip to console, switch
to root and edit /etc/fstab to add the following

// /mnt/smb smbfs
username=rngadam,password=******,uid=rngadam,gid=rngadam 0 0

I mounted it, cd'ed to the directory and did a ls that did not immediately return as expected... So I continued writing this, but after a while, I noticed that my desktop icons had disappeared and my console locked up. After trying a few things including switching to console as root and killing the smbmount process, I gave up and rebooted. After reboot, everything worked again, including the Windows share mount!

I then tried playing a few media files, but no success. Even a pretty basic MPEG2 video file has "No action associated to it"; Not exactly a multimedia powerhouse.

Apart from the install itself I would qualify my first 3 hours with it as bitter because it did not make things that should be simple, easy. At least not easier then before. Of course, I can debug the problems by frequent trips to the console as root as I usually do in all my Linux installs but I would certainly not recommend it to any newbie without some hand holding from me for a day to setup everything.

Many things I wish for, such as an easy way to switch to other input method (such as Chinese or Japanese) are not there yet. I believe the Sun Java Desktop now offers this, so there is hope...

Fedora Core 2's Workstation install has basic things I want missing (such as the samba-client). It doesn't cooperate well with Windows. And the kernel still locks up at boot when I try to install it on my Thinkpad A22m notebook making testing in a much more challenging hardware environment impossible.

However, I'm sure that with all the hard work the community is doing, Fedora Core 3 will be quite interesting...

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]