[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: some issues with nautilus MIME associations and thumbnails

Siddharth Toshniwal wrote:

Hi Dwaine, all

An update on these issues. Got some help from a friend.
The thumbnail generation was not working due to the JFIF
standard not being processed for some reason (my libjpeg
version is libjpeg-6b-31.1, do I need an update?).

Ran the 'file' command on an image for which a thumbnail
was generated properly and one for which it was not.

The output for the proper image (file1) was:
JPEG image data, JFIF standard 1.01, resolution (DPI), 144 x 144

and for the one without the thumbnail (file2) was:
JPEG image data, JFIF standard 1.02, resolution (DPI), 144 x 144

Opened the file2.jpg in gimp and saved it without any
changes. This changes the JFIF standard to the 'desired'
one (1.01) and thumbnail is shown :)

So there is a workaround for this issue at least. The MIME
association still has me stumped. Anyone with clues as to
what to do for that??


On Wed, 2004-05-26 at 17:45, Dwaine Garden wrote:

Siddharth Toshniwal wrote:

Hi all,

Have been facing a few issues with nautilus for the last
couple of days. I've upgraded my system (which was originally
RedHat 9) using up2date using the rawhide channel, so I
guess I may have some packages which are not working well
with each other. I don't know exactly which upgrade has
resulted in these problems, so I'm posting for help if
anyone has solved similar issues. The details are as follows:

* Nautilus does not show thumbnails for some of the images
within one directory while for others (which have the same
extension) it does so properly. Opening the images with
either eog or gimp does not report any errors.

* I seem to have some problem with *all* my MIME associations
(including the ones that are configured by default usually)
Even if I associate them manually (.jpg to eog, .doc to
star-office and so on), nautilus does not open the same
when I double click in the file window. I have to open
any documents using the terminal only :( The file association is shown correctly the next time I
double click the file and click on 'Associate', but
somehow the association does not work on its own.

The packages that I have installed are:

I read up the following article but it is not clear to me yet as to what I've done incorrectly:


I have the same problem with Konqueror. No thumbnails previews.


I can replicate the same problem here. The thumbnails in gimp do not work. Re-saving the jpeg file did produce the thumbnail in gimp.

The preview function in konqueror does not work either. And scanning in kooka in jpeg format does not produce any output. I did the same test with xsane and it worked just fine.

This is interesting.... Needs further investigation.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]