[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

MIME association woes, XDG_DATA_DIRS and so on (was: some issues with nautilus MIME associations and thumbnails)

Hi all,

No replies yet on this thread.... no one faced a similar
issue while doing a periodic RPM upgrade? 

I've dug some more into this issue and found another thread
which may be related to my problems, but no answers to that
thread as well. 

Read up the shared-mime-info spec and some other posts on
the gnomesupport.org site. With that I could make out that
I needed to export XDG_DATA_DIRS for some progress. I did
so in my .bashrc and .bash_profile (I guess I need have put
it in only one of them ideally, but anyways). 

After that my nautilus is showing PDF thumbnails (which it
was not earlier, so that's a nice discovery ;) but the file
associations are still not working (!?!??)

Now, shared-mime-info spec says that it does not tell which
application should be preferred to open which MIME type. It
may at most give a list of applications that 'can open' this
MIME type. So, where does the preference information reside??

Should I export some other environment variables (XDG_DATA_HOME
and so on) and if so, where? Or am I missing some package 
that I need to install?

To repeat, my problems currently are:

* Help files open in gedit even if I run yelp from
  the terminal after exporting the XDG_DATA_DIRS variable.

* No file association works on its own and double-clicking
  any file-type in nautilus just shows an error popup with the
  "no action associated" text.

Any help will be most welcome! :)


On Thu, 2004-05-27 at 16:11, Dwaine Garden wrote:
> Siddharth Toshniwal wrote:
> >Hi Dwaine, all
> >
> >An update on these issues. Got some help from a friend.
> >The thumbnail generation was not working due to the JFIF
> >standard not being processed for some reason (my libjpeg
> >version is libjpeg-6b-31.1, do I need an update?).
> >
> >Ran the 'file' command on an image for which a thumbnail
> >was generated properly and one for which it was not.
> >
> >The output for the proper image (file1) was:
> >JPEG image data, JFIF standard 1.01, resolution (DPI), 144 x 144
> >
> >and for the one without the thumbnail (file2) was:
> >JPEG image data, JFIF standard 1.02, resolution (DPI), 144 x 144
> >
> >Opened the file2.jpg in gimp and saved it without any
> >changes. This changes the JFIF standard to the 'desired'
> >one (1.01) and thumbnail is shown :)
> >
> >So there is a workaround for this issue at least. The MIME
> >association still has me stumped. Anyone with clues as to
> >what to do for that??
> >
> >thanks,
> >Siddharth.
> >
> >
> >
> >
> >On Wed, 2004-05-26 at 17:45, Dwaine Garden wrote:
> >  
> >
> >>Siddharth Toshniwal wrote:
> >>
> >>    
> >>
> >>>Hi all,
> >>>
> >>>Have been facing a few issues with nautilus for the last
> >>>couple of days. I've upgraded my system (which was originally
> >>>RedHat 9) using up2date using the rawhide channel, so I
> >>>guess I may have some packages which are not working well
> >>>with each other. I don't know exactly which upgrade has
> >>>resulted in these problems, so I'm posting for help if
> >>>anyone has solved similar issues. The details are as follows:
> >>>
> >>>* Nautilus does not show thumbnails for some of the images
> >>> within one directory while for others (which have the same
> >>> extension) it does so properly. Opening the images with
> >>> either eog or gimp does not report any errors.
> >>>
> >>>* I seem to have some problem with *all* my MIME associations
> >>> (including the ones that are configured by default usually)
> >>> Even if I associate them manually (.jpg to eog, .doc to
> >>> star-office and so on), nautilus does not open the same
> >>> when I double click in the file window. I have to open
> >>> any documents using the terminal only :( 
> >>> The file association is shown correctly the next time I
> >>> double click the file and click on 'Associate', but
> >>> somehow the association does not work on its own.
> >>>
> >>>The packages that I have installed are:
> >>> nautilus-media-0.8.0-2
> >>> nautilus-2.6.0-5
> >>> shared-mime-info-0.14-1
> >>> gnome-mime-data-2.4.1-4
> >>> gnome-vfs2-2.6.0-8
> >>>
> >>>I read up the following article but it is not clear to 
> >>>me yet as to what I've done incorrectly:
> >>>http://www.amitysolutions.com.au/documents/GnomeFiles-technote.pdf
> >>>
> >>>thanks,
> >>>Siddharth.
> >>>
> >>> 
> >>>
> >>>      
> >>>
> >>I have the same problem with Konqueror.   No thumbnails previews.
> >>
> >>Dwaine.
> >>    
> >  
> >
> I can replicate the same problem here.   The thumbnails in gimp do not 
> work.   Re-saving the jpeg file did produce the thumbnail in gimp. 
> The preview function in konqueror does not work either.   And scanning 
> in kooka in jpeg format does not produce any output.   I did the same 
> test with xsane and it worked just fine.  
> This is interesting....  Needs further investigation.
> Dwaine.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]