[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC3 does not boot with an own vanilla kernel



On Wed, 2004-11-10 at 12:34 -0600, RON FLORY wrote:

I know I did when I tried it, except i run mkinitrd manually.

 Could this have something to do with udev?  I noticed that if
I enabled the deprecated /dev FS, it broke in a slightly different
manner.  I suspect the problem is the FC3 environment expects a
magic combination of kernel options- I just have not been able to
stumble upon them yet...

Arjan van de Ven wrote:
hmm you need tmpfs enabled but beyond that... can't really think of
anything.

yeah, I just tried it again. Looking at .config, tmpfs is definitely enabled, but the boot process aborts with:

"Warning: unable to open an initial console."

and thats the last thing it does.

 I've tried this on perhaps 3 different makes/models of
x86 systems, all with same results.  In each case 'console'
is either local laptop or generic x86 HW.  I know this will
be simple when it finally makes sense...

ron

 P.S.  Also, what has to be enabled in the kernel to support
       the grub 'root=LABEL=/' directive?   I always have to
       supply literal 'root=/dev/hdax' with kernel.org kernels.

Thanks.

ron


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]