[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: FC4t2 no good without LILO



On Tue, 2005-04-12 at 15:23 -0700, Dana Lacoste wrote:
> Here's a question -- does grub work yet if your boot device is >2TB?
> I 
> just ran into this issue on RHEL4.  sda on my system is a ~3TB
> hardware 
> RAID5 (3ware).  I put a couple of small partitions at the beginning of
> the 
> disk for /, /var, and the like, the install seemed to go fine, but 
> afterward it wouldn't boot.  Booting into rescue mode and trying
> commands 
> from the grub prompt seems to indicate that the disk is too big for
> grub.
> 
> A simple 'lilo' in rescue mode made the system bootable.

Lilo on a > 2TB device is risky.  It has worked exactly once for me, and
never again.  Also, a > 2TB device requires a GPT disk label in order to
not eat the file systems created upon it.  Lilo cannot install to a GPT
disk partition last time I tried.  It barfed badly.

Work is about to begin (as Peter said) to make grub handle GPT disk
labels, which is necessary for > 2TB block devices.  This will allow
grub to boot a > 2TB root block device.

-- 
Jesse Keating RHCE      (geek.j2solutions.net)
Fedora Legacy Team      (www.fedoralegacy.org)
GPG Public Key          (geek.j2solutions.net/jkeating.j2solutions.pub)
 
Was I helpful?  Let others know:
 http://svcs.affero.net/rm.php?r=jkeating


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]