[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Why is rpm -qa | grep openoffice.org2 soooo slow?



On Tue, 2005-02-15 at 10:44 +0100, Michael Schwendt wrote:
>> 
>> real    6m28.496s
>> user    0m3.070s
>> sys     0m0.559s
>> [rodd localhost database]$
>
>One thing for certain, that doesn't look normal. Your test shows that the
>process took only roughly 3.6 seconds of CPU time. So it didn't compute a
>lot. Under normal circumstances, it would have terminated after less than
>four seconds. But possible it was interrupted very often or spent a lot of
>time waiting for I/O or locks. Processes which sleep often (I doubt RPM
>does that) would also increase the "real" execution time. Was your machine
>very busy when you ran this test?

Not that I'm aware of.  This isn't the first time I've seen this.  It's
been quite prevalent over the last few weeks(???).  I'm a little slack
with anything that's obvious because I figure (and rightly so most of
the time) that the developer knows and that they are doing something
about it.  If it's not addressed quickly, then I file a bug report
(after finding out if I'm a nut or not.)

I wasn't doing anything on the box at the time (no builds, no flash
movies, nothing I'm aware of).  the CPU indicator didn't suggest
anything was happening at the time (it was notably quite, which
surprised me I must admit)

Oh, and after setting the process running I went and got my 5 month old
out of the bath and dressed him for bed, so apart from a quick glance at
the screen, I wasn't doing any active work on the machine at the time.


Rodd


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]