[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: udev..



On Mon January 3 2005 12:29 pm, Arjan van de Ven wrote:
> On Mon, 2005-01-03 at 11:17 +0400, Manu Abraham wrote:
> > Hi,
> > 	I have a dvb module that has funny problems when loaded with udev ..
>
> which module ?
> Describe "funny problems"... right now it says nothing ;)
>
> > Is there
> > something specific that i should do in the driver to have normal
> > operation with udev ?
>
> udev doesn't load modules.... kudzu and co do however.
> I assume your module advertizes the pci id table properly?

This a query that i have received from one guy. If i ignore that udev is there 
altogether and make the devices using the MAKEDEV script, and load the 
modules, then things would be fine..

This point only made me think that something more should be done for udev ?
I maybe totally wrong here also..

Thanks,
Manu
--------------------------------------------------------------------------------------
I have created the dvb.sh script and dvb udev rules as per the readme. I am
modprobing the modules in the following order:-

bttv card=0x71 i2c_hw=1
dvb-bt8xx
dst

which gives me an lsmod like this:-

dvb_bt8xx               7972  0
dvb_core               75624  1 dvb_bt8xx
nxt6000                 6852  1 dvb_bt8xx
mt352                   5028  1 dvb_bt8xx
dst                    12360  1 dvb_bt8xx
bt878                   8596  2 dvb_bt8xx,dst
sp887x                  7492  1 dvb_bt8xx
tuner                  20772  0
bttv                  146832  2 dvb_bt8xx,bt878
video_buf              17412  1 bttv
firmware_class          7520  3 dvb_bt8xx,sp887x,bttv
v4l2_common             4576  1 bttv
btcx_risc               3752  1 bttv
videodev                7328  1 bttv

However, the bttv driver doesn't seem to be able to find a frontend for the
card. Here's what dmesg says.

Linux video capture interface: v1.00
bttv: driver version 0.9.15 loaded
bttv: using 8 buffers with 2080k (520 pages) each for capture
bttv: Host bridge needs ETBF enabled.
bttv: Bt8xx card found (0).
PCI: Found IRQ 10 for device 0000:00:0e.0
PCI: Sharing IRQ 10 with 0000:00:0e.1
bttv0: Bt878 (rev 17) at 0000:00:0e.0, irq: 10, latency: 66, mmio:
0x42100000
bttv0: detected: Twinhan VisionPlus DVB-T [card=113], PCI subsystem ID is
1822:0001
bttv0: using: Twinhan DST + clones [card=113,insmod option]
bttv0: enabling ETBF (430FX/VP3 compatibilty)
bttv0: gpio: en=00000000, out=00000000 in=00f9fcfe [init]
bttv0: using tuner=4
bttv0: add subdevice "dvb0"
bt878: AUDIO driver version 0.0.0 loaded
bt878: Bt878 AUDIO function found (0).
PCI: Found IRQ 10 for device 0000:00:0e.1
PCI: Sharing IRQ 10 with 0000:00:0e.0
bt878(0): Bt878 (rev 17) at 00:0e.1, irq: 10, latency: 66, memory:
0x42300000
DVB: registering new adapter (bttv0).
dvb-bt8xx: A frontend driver was not found for device 109e/0878 subsystem
1822/0001

I end up with a device for adapater0, like so:-

server log # ls /dev/dvb/adapter0
demux0  dvr0  net0

I'm not sure if this is a udev problem, or another issue. Any help is
greatly appreciated.
--------------------------------------------------------------------------------------


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]