[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: newest gimp won't run



On Mon, 2005-01-17 at 08:57 -0600, Harry Putnam wrote:
> I ran yum on all gimp packages .. installing:
> gimp-2.2.2-3
> gtkam-gimp-0.1.12-2
> gimp-data-extras-1.2.0-12
> gimp-print-plugin-4.2.7-3
> gimp-help-2-0.1.0.6.1
> gimp-print-4.2.7-3
> 
> No errors showed up.  But now when I attempt to run gimp.  I get a
> errors like this (and no gimp comes up):
> 
> 
>   (gimp:12373): GLib-GObject-WARNING **: specified class size for type
>   `GimpContainerEntry' is smaller than the parent type's `GtkEntry'
>   class size
>   
>   (gimp:12373): GLib-GObject-CRITICAL **: file gtype.c: line 2319
>   (g_type_add_interface_static): assertion `G_TYPE_IS_INSTANTIATABLE
>   (instance_type)' failed
>   
>   (gimp:12373): GLib-GObject-CRITICAL **: file gobject.c: line 819
>   (g_object_new): assertion `G_TYPE_IS_OBJECT (object_type)' failed
>   gimp: symbol lookup error: gimp: undefined symbol:
>   g_return_if_fail_warning

Is this an FC3 or an FC4 (development/Rawhide) system? I assume the
former -- in that case please install the package built for FC3 then
(gimp-2.2.2-0.fc3.3 should hit the download servers with then next
push), you shouldn't use Rawhide packages on FC3.

Nils
-- 
     Nils Philippsen    /    Red Hat    /    nphilipp redhat com
"They that can give up essential liberty to obtain a little temporary
 safety deserve neither liberty nor safety."     -- B. Franklin, 1759
 PGP fingerprint:  C4A8 9474 5C4C ADE3 2B8F  656D 47D8 9B65 6951 3011


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]