[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: python-sqlite3 dependency problem for yum today



On Sat, 2005-03-12 at 10:06 -0700, maxer wrote: 
> Processing Dependency: python-sqlite3 for package: yum
> --> Finished Dependency Resolution
> Error: Missing Dependency: python-sqlite3 is needed by package yum
> 
> yum --exclude=python-sqlite3\* update should work
> 
> RaXeT
> 

But watch out ... even though yum update said:
...
--> Running transaction check
--> Processing Dependency: python-sqlite3 for package: yum
--> Finished Dependency Resolution
Error: Missing Dependency: python-sqlite3 is needed by package yum

When I did:

yum update r\* b\*

yum thought it was OK to remove sqlite3

So now I have a broken system:

# rpm -qa | grep sqlite
sqlite-devel-3.1.2-1
python-sqlite3-1.1.6-1
sqlite-3.1.2-1
#

I guess python-sqlite3-1.1.6-1 is missing a dependency on sqlite3 and
after update yum no longer works

Regards :)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]