[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: yum/kudzu/kernel problem



Rodd Clarkson wrote:
On Sun, 2005-09-18 at 21:53 -0400, Jim Cornette wrote:

Mike Chambers wrote:

On Mon, 2005-09-19 at 11:16 +1000, Rick Marshall wrote:


none of this looks good:

(FC4 with devel updates)

Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package kernel.i686 0:2.6.13-1.1558_FC5 set to be installed
---> Package kudzu.i386 0:1.2.4-1 set to be updated
---> Package kernel-doc.noarch 0:2.6.13-1.1558_FC5 set to be updated
---> Package kudzu-devel.i386 0:1.2.4-1 set to be updated
--> Running transaction check
--> Processing Conflict: kudzu conflicts kernel < 2.6.13
Traceback (most recent call last):
File "/usr/bin/yum", line 27, in ?
  yummain.main(sys.argv[1:])
File "/usr/share/yum-cli/yummain.py", line 133, in main
  (result, resultmsgs) = base.buildTransaction()
File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 339, in buildTransaction
  (rescode, restring) = self.resolveDeps()
File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 254, in resolveDeps
  (checkdep, missing, conflict, errormsgs) = self._processConflict(dep)
File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 695, in _processConflict
  for pkg in pkgs:
TypeError: iteration over non-sequence


I didn't have this problem when I upgraded.  Did you let yum update
itself first before trying to do a system yum update?


kudzu gave me that output also. The rest of the packages updated without this sort of error. Kudzu is the only package that would not install for me. Yum and the kernel seem to be fine.

Jim


Yeah, I saw the same thing too.

have a look at what kernels you've got installed.

rpm -qa kernel\*

I'll bet there are a couple of kernels that are 2.6.11 or 2.6.12 (more
than like FC4 kernels).  Kudze won't work with these anymore (for some
reason).

remove these kernels and then kudzu will install.


Rodd


Thanks! I had a kernel from FC4 which was flagged since it was 2.6.12 series. Kudzu installed after removing the FC4 kernel.

Jim

--
QOTD:
	If it's too loud, you're too old.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]