[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

dependencies (was: Re: system-config-services - dead python)



On Thu, Jun 22, 2006 at 07:39:22PM -0400, Jim Cornette wrote:
> 
> The below packages are not upgraded due to dependency errors.
....
> nfs-utils-lib.i386                  1.0.8-5                development

Do you have by any chance installed an older version of 'nfs-utils'
(not '...-lib') with an "rc" string in a version identifier?  The
current version nfs-utils-1.0.8-2 comes as "rpm-older", so it is not
updated, but this is 1.0.8-2 which is using those libraries above.

It appears that the only way to get around that is to download an
rpm package for nfs-utils-1.0.8-2 and install it with '--nodeps
--oldpackage'.  Then there will be no conflict when you will try
to update to nfs-utils-lib-1.0.8-5.  This would be not a problem
if a packager used some higher "epoch" for nfs-utils but this
is currently not the case.

   Michal


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]