[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Cinema Display 30 and Radeon 9600




On Mar 1, 2006, at 4:15 AM, shrek-m gmx de wrote:

On 01.03.2006 03:36, Scott wrote:

The blank screen on install along with a copy of the X.log and X config from the install disk is something I will bugzilla. Might be nice though to see if I could gather more info other than 'it doesn't work' :)


is your problem the  "raedoen 9600"  or the "cinema display 30" ?
i have problems with the "radeon 9600" on a powermac and a "iiyama vision master pro 451

I do not know. As a wild guess I would say the problem is with the xorg radeon driver not supporting the dual link dvi mode needed to drive the Apple Cinema Display 30. I have seen working video in xorg 6.8.2 running the Radeon 9600 and the ACD 30 at 1024x768 under Ubuntu breezy when using the radeon driver. However, I still has the same issue of not being able to do native 2560x1600.

I loaded up FC5-test3 figuring I would try the latest xorg release I could find in a distro to see if the problem was something that had been fixed in the radeon driver or X11 code. So far though I have not been able to get video at 1024x678 like I had running with xorg 6.8.2 in Ubuntu.

So I _think_ the problem is with the video card or xorg driver than the ACD 30. I'm concerned, but not stressed out about, as to why I cannot seem to get any video at any resolution under xorg 7.0.0 in FC5-test3 where I could at least get 1024x768 under xorg 6.8.2 in Ubuntu. The real goal is to find out why I cannot get native 2560x1600 running. :)

Ihttps://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=180735
the resolution is not as expected but i am happy that X is running now.

Thanks for the link to this. Your xorg.conf and mine are identical as far as the radeon driver setup.

For reference here are the specs on the ACD 30: http://www.apple.com/ displays/specs.html. The following detected DDC data and panel type from the ACD 30 is accurate according to the specs I've seen:

(II) RADEON(0): I2C bus "DDC" initialized.
(II) RADEON(0): Legacy BIOS detected
(II) RADEON(0): Connector0: DDCType-2, DACType-0, TMDSType-1, ConnectorType-3 (II) RADEON(0): Connector1: DDCType-3, DACType-1, TMDSType-0, ConnectorType-3
(II) RADEON(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) RADEON(0): I2C device "DDC:ddc2" removed.
(II) RADEON(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) RADEON(0): I2C device "DDC:ddc2" removed.
(II) RADEON(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) RADEON(0): I2C device "DDC:ddc2" removed.
(II) RADEON(0): DDC Type: 3, Detected Type: 0
(II) RADEON(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) RADEON(0): I2C device "DDC:ddc2" removed.
(II) RADEON(0): DDC Type: 2, Detected Type: 3
(II) RADEON(0): EDID data from the display on port 2-----------------------
(II) RADEON(0): Manufacturer: APP  Model: 9232  Serial#: 33556679
(II) RADEON(0): Year: 2005  Week: 47
(II) RADEON(0): EDID Version: 1.3
(II) RADEON(0): Digital Display Input
(II) RADEON(0): Max H-Image Size [cm]: horiz.: 64  vert.: 40
(II) RADEON(0): Gamma: 2.20
(II) RADEON(0): DPMS capabilities: Off; RGB/Color Display
(II) RADEON(0): First detailed timing not preferred mode in violation of standard!
(II) RADEON(0): redX: 0.640 redY: 0.343   greenX: 0.292 greenY: 0.611
(II) RADEON(0): blueX: 0.146 blueY: 0.074   whiteX: 0.313 whiteY: 0.331
(II) RADEON(0): Manufacturer's mask: 0
(II) RADEON(0): Supported additional Video Mode:
(II) RADEON(0): clock: 71.0 MHz   Image Size:  641 x 401 mm
(II) RADEON(0): h_active: 1280 h_sync: 1328 h_sync_end 1360 h_blank_end 1440 h_border: 0 (II) RADEON(0): v_active: 800 v_sync: 803 v_sync_end 809 v_blanking: 823 v_border: 0
(II) RADEON(0): Supported additional Video Mode:
(II) RADEON(0): clock: 268.0 MHz   Image Size:  641 x 401 mm
(II) RADEON(0): h_active: 2560 h_sync: 2608 h_sync_end 2640 h_blank_end 2720 h_border: 0 (II) RADEON(0): v_active: 1600 v_sync: 1603 v_sync_end 1609 v_blanking: 1646 v_border: 0
(II) RADEON(0): Serial No: CY54703AUG1
(II) RADEON(0): Monitor name: Cinema HD
(II) RADEON(0): Number of EDID sections to follow: 1
(II) RADEON(0):
(II) RADEON(0): Primary:
Monitor   -- TMDS
Connector -- DVI-I
DAC Type  -- Primary
TMDS Type -- External
DDC Type  -- DVI_DDC
(II) RADEON(0): Secondary:
Monitor   -- NONE
Connector -- DVI-I
DAC Type  -- TVDAC/ExtDAC
TMDS Type -- Internal
DDC Type  -- VGA_DDC
(II) RADEON(0): PLL parameters: rf=2700 rd=12 min=20000 max=40000; xclk=27000 (WW) RADEON(0): Failed to detect secondary monitor, MergedFB/Clone mode disabled
(==) RADEON(0): Using gamma correction (1.0, 1.0, 1.0)
(II) RADEON(0): Validating modes on Primary head ---------
(II) RADEON(0): DFP table revision: 4
(II) RADEON(0): Panel infos found from DDC detailed: 1280x800
(II) RADEON(0): Panel infos found from DDC detailed: 2560x1600
(II) RADEON(0): Valid Mode from Detailed timing table: 1280x800
(II) RADEON(0): Valid Mode from Detailed timing table: 2560x1600
(II) RADEON(0): Total of 2 mode(s) found.
(II) RADEON(0): Total number of valid DDC mode(s) found: 2
(--) RADEON(0): Virtual size is 2560x1600 (pitch 2560)

--
Scott


Attachment: smime.p7s
Description: S/MIME cryptographic signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]