[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

GLX with the nv driver



On 3/1/06, David Timms <dtimms bigpond net au> wrote:
> Jonathan Berry wrote:
> > Are you able to run glxgears with the nv (open-source) driver?  It
> > does not work for me (x86_64 PCI-e 6600 GT):
>
> Yes, the above slow results are with nv (ie default installer chosen
> driver / config) - there is no error, however it appears that the gears
> are not being clearly updated on the screen; CPU use goes to 100% but I

I think this is normal.  It's the same effect as when looking at a
car's wheels and it looks like the wheels are rotating backwards.  The
gear rotation rate is at just the right speed relative to everything
else to where they don't appear to move as much as they do.  In FC4
with the nvidia driver, I get around 11,000 FPS and it appears that 
the gears stutter a little.

> think that would be normal :)

Yes, 100% CPU usage is normal.

> from /var/log/X log:
> (II) LoadModule: "nv"
> (II) Loading /usr/lib/xorg/modules/drivers/nv_drv.so
> (II) Module nv: vendor="X.Org Foundation"
>          compiled for 7.0.0, module version = 1.0.1
>          Module class: X.Org Video Driver
>          ABI class: X.Org Video Driver, version 0.8
> ...
> (II) NV: driver for NVIDIA chipsets: RIVA 128, RIVA TNT, RIVA TNT2,
> ...
> (--) Chipset GeForce FX 5600 found
> ...
> (II) NV(0): Using XFree86 Acceleration Architecture (XAA)
>          Screen to screen bit blits

I get the same messages in my log (except mine is a 6600 GT).  I
wonder what the difference is.  Yours is 32-bit arch, right?  Is your
card a PCI, AGP, or PCI-e card?  Mine is 64-bit arch, PCI-e card. 
Perhaps it is time for a bug report.

Jonathan


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]