[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Cinema Display 30 and Radeon 9600



Scott wrote:

On Mar 1, 2006, at 4:15 AM, shrek-m gmx de wrote:

On 01.03.2006 03:36, Scott wrote:

The blank screen on install along with a copy of the X.log and X config from the install disk is something I will bugzilla. Might be nice though to see if I could gather more info other than 'it doesn't work' :)



is your problem the  "raedoen 9600"  or the "cinema display 30" ?
i have problems with the "radeon 9600" on a powermac and a "iiyama vision master pro 451


I do not know. As a wild guess I would say the problem is with the xorg radeon driver not supporting the dual link dvi mode needed to drive the Apple Cinema Display 30. I have seen working video in xorg 6.8.2 running the Radeon 9600 and the ACD 30 at 1024x768 under Ubuntu breezy when using the radeon driver. However, I still has the same issue of not being able to do native 2560x1600.

I loaded up FC5-test3 figuring I would try the latest xorg release I could find in a distro to see if the problem was something that had been fixed in the radeon driver or X11 code. So far though I have not been able to get video at 1024x678 like I had running with xorg 6.8.2 in Ubuntu.

So I _think_ the problem is with the video card or xorg driver than the ACD 30. I'm concerned, but not stressed out about, as to why I cannot seem to get any video at any resolution under xorg 7.0.0 in FC5-test3 where I could at least get 1024x768 under xorg 6.8.2 in Ubuntu. The real goal is to find out why I cannot get native 2560x1600 running. :)

Ihttps://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=180735
the resolution is not as expected but i am happy that X is running  now.


Thanks for the link to this. Your xorg.conf and mine are identical as far as the radeon driver setup.

For reference here are the specs on the ACD 30: http://www.apple.com/ displays/specs.html. The following detected DDC data and panel type from the ACD 30 is accurate according to the specs I've seen:

You need to use proprietary drivers with the 30" flat panels from Apple
or Dell to get it working as one would expect.  That probably wont
change much until the video hardware vendors wake up and start
supporting OSS again.

I would _love_ to buy 2 of the Dell 30" panels, and would do it in a
heartbeat if I could get everything to work properly with the OSS
drivers we ship with the OS.  I refuse to use proprietary drivers in
Linux on my desktop, so such cool display hardware is not on my
radar at least until there are OSS drivers that support them.

Maybe Intel or someone will come to the rescue with new hardware in
the future, and solving the modesetting problems in the OSS Intel
driver currently.

Very lame to have such cool hardware available, and fairly craptastic
support for it in Linux/X.

I've stuck with ATI FireGL 8800 boards for the last number of years
after the R200 DRI support was added to X, and had good results, but
that doesn't help much with the snazzy 30" display problem. ;o/

Matrox has some funky new hardware with fibre optic connectors that
looks nifty.  It'll be interesting to see if they provide OSS support
for it. ;o)

For now, I'll probably stick with FireGL 8800 until the fan dies on
it.



--
Mike A. Harris  *  Open Source Advocate  *  http://mharris.ca
                      Proud Canadian.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]