[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Suspend





On 3/3/06, Phil Knirsch <pknirsch redhat com> wrote:
D Canfield wrote:
> Don Springall wrote:
>
>>
>> Is suspend/resume broken in rawhide for Kernel 2.6.16-rc5-git4 ? It
>> last worked for me in 2.6.16-rc5. Not seeing anything breaking in dmesg.
>>
>> I get I/O and then the screen flickers but stays blank. At that point
>> I have to pull the plug on power. ACPI messages look ok.
>
> I haven't had time to do a lot of testing, but suspend stopped working
> on my Thinkpad T43 (ATI Chipset, DRI turned off since this is the only
> way suspend has ever worked for me) sometime in the past week or two as
> well.  And mere weeks after it had finally started working... :-(
>
> DC
>

I've done a few changes to the ATI scripts over the last few weeks
because we had at least one report where the old script failed. It looks
like this causes much more problems though than it solves, so i'm
reverting the changes back to what we had previously.

Attached is the original functions-ati from /etc/pm/functions-ati which
i'm putting back in as we speak.

Please give it a try with that one and let me know if it works. If it
doesn't then it's most likely a kernel bug that got introduced over the
last few weeks.

Read ya, Phil

--
Philipp Knirsch      | Tel.:  +49-711-96437-470
Development          | Fax.:  +49-711-96437-111
Red Hat GmbH         | Email: Phil Knirsch <phil redhat de>
Hauptstaetterstr. 58 | Web:   http://www.redhat.de/
D-70178 Stuttgart
       Kaa's Law: In any sufficiently large group of people most are idiots.


#!/bin/bash


get_lcd_status()
{
        if [ ! -x /usr/sbin/radeontool ]; then
                echo "error"
                return 2
        fi
        STATUS=$(/usr/sbin/radeontool light | cut -d\  -f5 2>/dev/null)
        RETVAL=0
        case "x$STATUS" in
                "xon")
                        echo "on"
                        RETVAL=0
                        ;;
                "xoff")
                        echo "off"
                        RETVAL=1
                        ;;
                *)
                        echo "error"
                        RETVAL=2
                        ;;
        esac
        return $RETVAL
}

lcd_off()
{
        if [ "$(get_lcd_status)" != "on" ]; then
                return
        fi
        [ -x /usr/sbin/radeontool] && /usr/sbin/radeontool light off
}

lcd_on()
{
        if [ "$(get_lcd_status)" != "off" ]; then
                return
        fi
        [ -x /usr/sbin/radeontool ] && /usr/sbin/radeontool light on
}

get_crt_status()
{
        if [ ! -x /usr/sbin/radeontool ]; then
                echo "error"
                return 2
        fi
        STATUS=$(/usr/sbin/radeontool light | cut -d\  -f5 2>/dev/null)
        RETVAL=0
        case "x$STATUS" in
                "xon")
                        echo "on"
                        RETVAL=0
                        ;;
                "xoff")
                        echo "off"
                        RETVAL=1
                        ;;
                *)
                        echo "error"
                        RETVAL=2
                        ;;
        esac
        return $RETVAL
}

crt_off()
{
        if [ "$(get_lcd_status)" != "on" ]; then
                return
        fi
        [ -x /usr/sbin/radeontool ] && /usr/sbin/radeontool dac off
}

crt_on()
{
        if [ "$(get_lcd_status)" != "on" ]; then
                return
        fi
        [ -x /usr/sbin/radeontool ] && /usr/sbin/radeontool dac on
}

[ -x /usr/sbin/vbetool ] || return

suspend_video()
{
(
        /usr/sbin/vbetool dpms suspend
) >/dev/null 2>&1
}

resume_video()
{
(
        /usr/sbin/vbetool dpms on
) >/dev/null 2>&1
}


--
fedora-test-list mailing list
fedora-test-list redhat com
To unsubscribe:
https://www.redhat.com/mailman/listinfo/fedora-test-list

About 3 days ago, my laptop (Dell Latitude D600) stopped coming back from suspend, the hd light flickered but the screen wouldn't come back.

I replaced with this, and I got my screen back, howerver my network didn't reconnect and had to run
dhclient eth0

I am at work at the moment and it is on a docking station if that matters./?

lspci -v | grep VGA

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R250 Lf [FireGL 9000] (rev 02) (prog-if 00 [VGA])


# lspci -v | egrep -i 'network|ethernet'
02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5705M Gigabit Ethernet (rev 01)
02:03.0 Network controller: Intel Corporation PRO/Wireless 2200BG (rev 05)




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]