[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: mono-beagled -- major memory leak



On Tue, 2006-03-07 at 21:56 -0800, Nathanael D. Noblet wrote:
> On Tue, 2006-03-07 at 23:52 -0600, Jonathan Berry wrote:
> 
> > > >Is anyone else seeing this?  I'm assuming that it is not supposed to
> > > >do that.  Any ideas about how to debug this?
> > > >
> Yes I've experienced the same behaviour a couple times. The most recent
> this afternoon. It took 5 minutes to have the system respond enough so I
> could kill it. It swallowed 300MB of my 512MB RAM and was seriously
> thrashing my storage.
> 
> > Well, I didn't mention high CPU usage as I didn't really notice that. 
> > I also am not really sure exactly what the above means.  I did notice
> > that something locked up my disk really well accessing it for a short
> > while.  The I/O wait cycles tied up the entire CPU, so I wasn't able
> > to do much to find out what program it was, but it seems likely to
> > have been beagled.
> 
> I had load numbers nearing 9 when I finally got the beagle program
> killed.
> 
> 
I too have just tracked down some nasty problems to beagled malicing my
system.  It was when I was gaming every 30 seconds or so my entire IO
system would stop responding for a second or so.  I also found it was
locking up my system when I was running eclipse and working on the
repository in my home directory.

The most frustrating part was my inability to turn it off.  If I removed
it from gnome-session it always found its way back on login, and then
having a cron job to start it up as well is just wrong.

I have come to terms with accepting mono apps on fedora ( I love tomboy
and f-spot )  but beagle seems to still need some work.

Jon


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]