[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: which drivers compiled in wpa_supplicant



On Fri, 2006-03-10 at 14:26 +0100, Roger Grosswiler wrote:
> > On Fri, 2006-03-10 at 07:51 +0100, Roger Grosswiler wrote:
> >> Hey,
> >>
> >> which drivers are compiled in the rpms of wpa_supplicant?
> >>
> >> As i know, the following are supported:
> >>
> >> Host AP driver for Prism2/2.5/3(WPA and WPA2)
> >> Linuxant DriverLoader with Windows NDIS driver supporting WPA (WPA, but
> >> not WPA2)
> >> Agere Systems Inc. Linux Driver (Hermes-I/Hermes-II chipset) (WPA, but
> >> not
> >> WPA2)
> >> madwifi (Atheros ar521x)
> >> ATMEL AT76C5XXx
> >> Linux ndiswrapper
> >> Broadcom wl.o driver
> >> Intel ipw2100
> >> Intel ipw2200
> >> Wired Ethernet drivers
> >> BSD net80211 layer (e.g., Atheros driver) (FreeBSD 6-CURRENT and NetBSD
> >> current)
> >> Windows NDIS drivers (Windows; at least XP and 2000, others not tested)
> >>
> >>
> >> ...but you have to fiddle out the .config-file. So i really just want to
> >> know, for which drivers it has been compiled.
> >
> > http://cvs.fedora.redhat.com/viewcvs/devel/wpa_supplicant/wpa_supplicant.config?view=markup
> >
> > Note that the madwifi driver is compiled for _madwifi-ng_, not the older
> > madwifi.
> >
> > Dan
> >
> >
> Ah, btw. which drivers are supported out of the box? madwifi? ndiswrapper?
> ipw? prism?

Are you asking which drivers wpa_supplicant supports out of the box?

If so, any drivers that are listed in the config file there, and that
wpa_supplicant reports as supported on it's website for 0.4.8, should be
supported by wpa_supplicant.  Known exceptions: bcm43xx, madwifi-ng
(both have intermittent problems caused by unstable or incomplete
drivers)

Or, if you're asking which drivers that Fedora Core 5 supports out of
the box, that's a different question.

Dan



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]