[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: System slowness with latest updates



On 12/03/2006, at 10:18 AM, David Timms wrote:
dragoran wrote:
Steven Haigh wrote:
On Sat, March 11, 2006 3:17 pm, Steven Haigh wrote:
As a followup to this, I've noticed that the syslog is around 3-4 minutes behind the events that happen. say I login to an IMAP server, the maillog shows the login at 16:57:48 - if I breat out of that and show the date, the clock will show 3-4 minutes later (ie 17:01) - even though the line
has only appeared seconds ago.

Even things such as spamassassin is taking 217 seconds to scan a 2Kb
email. snmpd results to localhost are timing out - even though the process
is listening.

It takes 45-50 seconds to log out of a su shell back to the logged in
user, the same for becoming root via 'su -'.

I have never seen this kind of behaviour on a system before - especially when the CPU is 99% idle. Has anyone come across this type of behaviour
before?

the system is:
model name      : AMD Sempron(tm) Processor 2800+
stepping        : 0
cpu MHz         : 1602.495

It has 1 Gb of RAM, and seemed to work perfectly until last nights updates.


have you tryed a different kernel?
And which one are you using while seeing this ?

Can you check /etc/hosts and or post it here; I saw similar things when I accidently removed my machine host name from /etc/hosts ? Or maybe it doesn't have the localhost entry and net stuff is timing out.
ping localhost
ping {machine host name}
ping {gateway}

Second guess, that I have noted with win machines at the office - every now and then win will set the netcard link to 100/Full or alternatively to Auto, when it needs to be the other way (for win to boot properly - depends on net card). This makes everything on the machine run really slowly (opening any app - which tries to reference network printers, because the card then communicates at 10/half, but in short responses - and never gets more than 100 Bytes/sec etc). I have never seen this on Fedora, though.

Thanks for the suggestions! I'd tried most of these before I posted. The network cards I have *always* negotiate the wrong duplex setting with my cisco switch and I have to lock them at 100/FD with mii-tool. This wasn't the issue however.

After playing around more and more and having things sometimes work, sometimes not, I thought it may be a hardware fault - so I swapped over a lot of hardware to see if that was the case (maybe dud ram?). This made no difference. I even went as far as reinstalling the entire system with FC4 and applying all updates - with no change.

What I finally found out is that as I use this box for remote logging (cisco equipment logs to it), it seems that the -x option was not in the config file (/etc/sysconfig/syslog) which was causing the system to look up EVERY entry for EVERY machine that tried to write a line to the syslog. As soon as I added -x to the syslog command line and restarted syslog, the system started purring away as it has done for the last few years.

I wish the -x option would be there by default - as it would have certainly saved me a LOT of pain. :)

--
Steven Haigh

Email: netwiz crc id au
Web: http://www.crc.id.au
Phone: (03) 9017 0597 - 0412 935 897





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]