[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: no floppy dir in /media ?



On Mon, Mar 13, 2006 at 08:50:24AM +0100, Larry tb wrote:
> 
> The problem i had, was to guess this new command. I often work at shell, 
> and so... Here is my problem :
> root ws044 ~]# mount /dev/fd0 /media/floppy
> mount: mount point /media/floppy does not exist
> [root ws044 ~]#
> 
> Of course the possibility/necessity is to create a /media/floppy, or 
> even /mnt/floppy. BUT within fc4 it was auto created during installation.

There is no /media/floppy because 'gnome-mount/gnome-umount' creates
and deletes these mount points and if you happen to have
/media/floppy, regardless if currently in use or not, then it will
be _not_ reused and /media/floppy-1, and if the last one is stuck
for whatever reason then /media/floppy-2 will show up and so on.

I do not like very much that design as, among other things, it is
obviously lacking in robustnes.  If anything goes wrong you are
ending up with a mess in /media/ which only root can clean up even
if non-root processes were responsible for it.  This is the next
thing which requires "special handling" if you try to have /
read-only.  Old user habits and lessons learned were not taken in a
consideration too.  Moreover you have to substitute your best guess
for a documentation.  But at the moment things are like they are.

   Mcihal


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]