[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: SMP mptable bad signature



Hey,

I read somewhere else that if I have ACPI enabled, then the kernel shouldn't even be checking for the SMP table (http://www.ussg.iu.edu/hypermail/linux/kernel/0311.1/0971.html). I have a Toshiba satellite (2340-S256), and as far as I know, ACPI is working (at least it looks fine in the info reported by dmesg). I suppose I'll try re-flashing the bios, but I'm pretty sure I already have the latest bios running. I have my doubts that my machine is supposed to be SMP capable. SMP has to do with multi-processor/hyper-threading systems, right? If so, then I know my system has no such features. I just wanted to be sure nothing was being broken by this new error.

Thanks for your help,
Mike

Dave Jones wrote:

On Thu, Mar 16, 2006 at 10:48:36AM -0500, Mike Leahy wrote:
 > Hello list,
 >
 > After updating to the most recent kernel (kernel-2.6.15-1.2054_FC5), I
 > started getting a new error at startup.  At the point where I would
 > normally see a whole bunch of stuff like messages from SELinux and udev
 > whiz by, I only get one error message, that says something like "SMP
 > mptable: bad signature (0x0)", followed by "BIOS bug: MP Table errors
 > detected (see hw vendor)".  After that, the kernel starts to boot, and
 > the Fedora interface begins loading.
 >
 > I'm not sure if this error was always there, but until now I have never
 > seen it.  It may be that I just never saw it because of all the
 > SELinux/udev messages and such that normally scrolled by before (the
 > older kernel that I have installed is kernel-2.6.15-1.2032_FC5, and it
 > still shows these startup messages).  The machine seems to have booted
 > fine, and despite not seeing any SELinux/udev messages at the initial
 > startup, everything seems to be working the same as before.  Is there
 > anything I should try in order to fix this SMP error, or can it safely
 > be ignored?

It's a BIOS bug, nothing we can do to fix it.
Check for an update on the manufacturers site ?

I've seen broken variants of this BIOS table appear on some systems that
aren't actually SMP capable, so it appears when you run an SMP kernel
on UP hardware (Like say, the newer VIA's so that it takes advantage
of NX, or x86-64 in FC5 to save distributing a second kernel).
In those cases, it also spits out 'disabling SMP', which isn't really
a big deal, as the machine is UP anyway. In that case, it's harmless, but noisy.

		Dave


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]