[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC Pre 6 test install



On Sun, 2006-10-01 at 18:22 -0700, MIKE LURK wrote:
> This is for all of the nVidia proponents out there that are having
> trouble getting FC pre 6 installed with all the eye candy. This
> install was done using the DVD iso. It was a chore getting this to run
> as designed but it was well worth the effort. It's a bit long
> 
> 1. Boot from DVD (naturally when you have a DVD from iso)
> 2. Choose the defaults for your keyboard, language and
> timezone.........
> 3. For the partitioning of the drive I left it with the defaults
> chosen. ( couldn't change anythingthing other wise it would error at
> trying to create a new partition, will try this again later to see if
> it was a hardware problem or if it was something to do with LVM).
> 4. Choose what you want to install and continue. (I know I skipped the
> network stuff and others as well but keeping in mind I am just using
> defaulta here. Later I will change a few things).
> 5.Finished the install. Remove DVD from drive and let it reboot.
> 6.On the First Boot screen, everything is shifted to the right so I
> can't see the next button. Then remembered in the mailing list about
> removing the rhgb from grub.
> 7. Removed rhgb from grub and booted to First Boot screens and chose
> what I needed. Continuing
> 8. Enter user name and password at the login screen.
> 9.1600x1200 resolution, Not good, beyond my monitors range, but still
> viewable. Downloading latest beta from nVidia's website. (following
> the readme, I went to the next step)
> 10. Installed driver and dependancies. (running the installer for the
> first time I found that I was missing  a few. Using yum I installed
> them, gcc and others. Finished the driver install.) Let the installer
> run the nVidia xconfigurator.
> 11.Reboot computer and login. 1280x1024, very good. Tried to get
> Desktop Effects ot run (Preferences>More Prefereces>Desktop Effects)
> failed.
> 
> Below you will see what my xorg.conf had to be for the Effects to
> work:

I just let FC6 do the default nvidia driver out of the box.
Yes, I get cannot enable desktop effects.  So, I need the nvidia
proprietary drivers?



> 
> # nvidia-xconfig: X configuration file generated by nvidia-xconfig
> # nvidia-xconfig:  version 1.0  (buildmeister builder3)  Thu Sep 14
> 15:50:24 PDT 2006
> 
> # Xorg configuration created by system-config-display
> 
> Section "ServerLayout"
>     Identifier     "single head configuration"
>     Screen      0  "Screen0" 0 0
>     InputDevice    "Mouse0" "CorePointer"
>     InputDevice    "Keyboard0" "CoreKeyboard"
> EndSection
> 
> Section "Files"
> EndSection
> 
> Section "Module"
>     Load           "dbe"
>     Load           "extmod"
>     Load           "fbdevhw"
>     Load           "glx"
>     Load           "record"
>     Load           "freetype"
>     Load           "type1"
> EndSection
> 
> Section "InputDevice"
>     # generated from default
>     Identifier     "Mouse0"
>     Driver         "mouse"
>     Option         "Protocol" "auto"
>     Option         "Device" "/dev/input/mice"
>     Option         "Emulate3Buttons" "no"
>     Option         "ZAxisMapping" "4 5"
> EndSection
> 
> Section "InputDevice"
>     Identifier     "Keyboard0"
>     Driver         "kbd"
>     Option         "XkbModel" "pc105"
>     Option         "XkbLayout" "us"
> EndSection
> 
> Section "Monitor"
> 
>  ### Comment all HorizSync and VertSync values to use DDC:
>     Identifier     "Monitor0"
>     ModelName      "Samsung SyncMaster 910V/910M/913V"
>     HorizSync       30.0 - 81.0
>     VertRefresh     56.0 - 75.0
>     Option         "dpms"
> EndSection
> 
> Section "Device"
>     Identifier     "Videocard0"
>     Driver         "nvidia"
>     VendorName     "Videocard vendor"
>     BoardName      "nVidia Corporation GeForce 7600"
> EndSection
> 
> Section "Screen"
>     Identifier     "Screen0"
>     Device         "Videocard0"
>     Monitor        "Monitor0"
>     DefaultDepth    24
>     SubSection     "Display"
>         Viewport    0 0
>         Depth       24
>         Modes      "1280x1024"
>     EndSubSection
> EndSection
> 
> Voila, the Desktop Effects works, for me anyways (luckily I had a copy
> of my FC 5 xorg.conf handy. Compare the differences between FC 5 and
> FC pre 6 ).
> There are many other issues with FC pre6. The hosts file has the
> loopback IP as ::1 when it should be 127.0.0.1 when using ipv4. The
> xorg nv driver does not recognize the proper resolution for the
> monitor( or maybe hal). The terminal window is just a white square.
> There are others as well. Glad to see you are delaying the release of
> FC6.
> 
> Ta Ta
> Mike
> 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]