[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: pre6 upgrade: X starts, but only the cursor



sean darcy wrote:
After a yum update since from pre 6 X won't start up completely. Actually X starts - I get the x mouse cursor, and Xorg.0.log looks fine. But that's it: just the x mouse cursor against a black background.

Tried switchdesk kde ( usually use gnome ) and xfce. Same result.

I downgrade metacity to metacity-2.16.0-4.fc6.x86_64. Again same result.

I've updated to rawhide x86-64 as of today.

I'd file in bugzilla, but I don't even know what to file against.

Any ideas on how to figure this one out would be appreciated.

sean


Do you know what type of video card your computer has?
I'd try to rename xorg.conf to xorg.conf.broke and then trying to start X. This should use the built-in configuration instead of the traditional configuration.

If X still only gives you a blank screen, copy xorg.conf.broke to /etc/X11/xorg.conf and change your current driver entry in the xorg.conf file from whatever driver you now use to the vesa driver. Try to start X with the change to see if you are able to start the GUI. Of course the best runlevel to run would be runlevel 3. This runlevel will prevent the dreaded respawning of a broken GUI configuration.

I don't think the blank screen is due to the window manager or the particular desktop you are using.

When filing a bug, filing the bug against the driver that your video card is using is probably the best way to start.

Also, the logs you should attach are /var/log/Xorg.0.log if you get this while X is not working. The log for Xorg.0.log.old would be for the failed driver if you started X with the vesa video driver. You probably should supply the /etc/X11/xorg.conf file that was originally installed that shows the problem.

Just a few ideas.
Jim

--
O'Brian's Law:
	Everything is always done for the wrong reasons.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]