[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Unable to build NVIDIA kernel module



søn, 08 10 2006 kl. 16:40 -0400, skrev Ian Lists. Marks:
> Has anyone been able to build the latest stable NVIDIA driver in the last couple kernel updates on Core6 pre?  Everything was working great until kernel-2.6.18-1.2741 I believe.  I tried upgrading to kernel-2.6.18-1.2747 and am having the same problem.  Below is the error in the nvidia-installer.log file I am seeing.
> 
>    /nv/nv.c:14:
>    include/asm/io.h: In function ‘check_signature’:
>    include/asm/io.h:245: warning: wrong type argument to increment
>    make[4]: *** [/tmp/selfgz3357/NVIDIA-Linux-x86-1.0-8774-pkg1/usr/src/nv/nv.o
>    ] Error 1
>    make[3]: *** [_module_/tmp/selfgz3357/NVIDIA-Linux-x86-1.0-8774-pkg1/usr/src
>    /nv] Error 2
>    make[2]: *** [modules] Error 2
>    NVIDIA: left KBUILD.
>    nvidia.ko failed to build!
>    make[1]: *** [mdl] Error 1
>    make: *** [module] Error 2
> -> Error.
> ERROR: Unable to build the NVIDIA kernel module.
> ERROR: Installation has failed.  Please see the file
>        '/var/log/nvidia-installer.log' for details.  You may find suggestions
>        on fixing installation problems in the README available on the Linux
>        driver download page at www.nvidia.com.

Nvidia' kernel module is up to them to support.

- David Nielsen


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]