[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: titlebars with aixgl and nvidia drivers fc6



On Tue, 2006-10-17 at 12:10 -0500, Marc Schwartz wrote:
> Kristian Høgsberg wrote:
> > Adam Jackson wrote:
> >> Gianluca Cecchi wrote:
> >>> Hello all,
> >>> after applying what explained in various postings, I can enable
> >>> desktop effects in my updated fc6 system with 9625 beta nvidia drivers
> >>> (installed by nvidia package) under the preferences submenu.
> >>> Only problem is about titlebars and windows borders disappearing.
> >>> Found some threads about this, but nothing solving my problem.
> >>> They suddenly appears as I disable again desktop effects.
> >>
> >> Make sure gnome-window-decorator is running, otherwise it's nVidia's bug.
> > 
> > I've seen this too, with gnome-window-decorator running, so it looks 
> > like there's a problem with nvidia's driver, but it could also be 
> > something with our compiz patch set, I guess.
> > 
> > Kristian
> 
> There is a known bug with the 9625 and the new 9626 beta drivers 
> pertaining to the implementation of the TFP (texture from pixmap) 
> functionality. This appears to result in various issues with compositing 
> managers, whether it be compiz, compiz-quinn or beryl.
> 
> nVidia is aware of this and is hopefully moving forward with a fix.  It 
> appears to be related to the amount of video ram available. So it will 
> show up at varying times depending upon how much video ram is being used 
> as a consequence of how many apps/windows are open, how many displays 
> are being run (ie. single display versus TwinView), and so forth.
> 
> I posted a "me too" bug report on this yesterday here (#13):
> 
>    http://www.nvnews.net/vbulletin/showthread.php?t=77248
> 
> and take note of post #4 by jamesjones.
> 
> Many of the reports that I have seen in various forums regarding the 
> presence or lack of window decorations, white/black/blank windows/cubes, 
> etc. may be an outcome of this underlying issue.  The white window/cube 
> issue seems to be more prevalent with XGL installations as opposed to 
> AIGLX systems.
> 
> Note that previously, I had used XGL on my FC5 system with the current 
> stable nVidia driver (8774) and had compiz-quinn running without 
> problems. So we seem to be in a bit of transition with nVidia's current 
> beta drivers supporting TFP and the use of AIGLX.
> 
> HTH,
> 
> Marc Schwartz
> 

I know most have already tried this but I thought it might help the new
guys.

This is how a few people have gotten the borders to show up.
Under Section "ServerLayout" add
	Option		"AIGLX"	"true"
Under Section "Device" add
	Option	"AddARGBGLXVisuals" "on"
also make sure your screen depth is set to 24, I can not get it to work
set at 32
I'm using nvida beta driver 9625 (didn't know ther was a new one) and
still stuck on T3 YMMV

HTH someone


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]