[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: problem with yum



One possible solution would be downloading latest versions of all
"doubled" packages and installing them manually: rpm -Uvh <package
names>

On 9/4/06, parta <pritam ghanghas gmail com> wrote:
Hi

Actually it will be wrong to say that Its a problem with yum. I ran "yum
update" . Everthing was going well until I accidently pressed Ctl-c when yum
was cleaning up old packages( Last step when yum updates). Now when I view
the installed packages by doing
"yum -qa | sort"
I see multiple versions of the same package. I looked at yum manpage, but no
help. Can I do that cleanup process manually.
may be I can try manually erasing the old rpm packages. But I am not sure
whether the two versions share some binary files or not.
If they share binary files, then this option gets ruled out as it will erase
usefull files. I dont know what yum does internally. I have  tried
rebuilding the rpm database and yum clean all. But no help.

Can I let the system remain as it is? Are the multiple packages only entries
in yum database or I am having two version of the same software (seems
unlikely)? Wont it create any problem? I dont care if these packages are
taking a little space as long as they dont create any problem to system
functionality.

Thanks In advance.
--
pritam
--
fedora-test-list mailing list
fedora-test-list redhat com
To unsubscribe:
https://www.redhat.com/mailman/listinfo/fedora-test-list




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]