[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Apache won't start. php-eaccelerator not compiled for version of PHP



I'm not sure when this exactly happened. I don't use Apache a huge
amount on my machine. Only for testing.

When I try to start Apache I get this in the error logs:
[Thu Sep 07 14:10:50 2006] [notice] suEXEC mechanism enabled (wrapper:
/usr/sbin/suexec)
[Thu Sep 07 14:10:50 2006] [notice] Digest: generating secret for
digest authentication ...
[Thu Sep 07 14:10:50 2006] [notice] Digest: done
PHP Warning:  [eAccelerator] This build of "eAccelerator" was compiled
for PHP version 5.1.4. Rebuild it for your PHP version (5.1.6) or
download precompiled binaries.\n in Unknown on line 0
PHP Fatal error:  Unable to start eAccelerator module in Unknown on line 0

When I check the status of apache I get this:
# service httpd status
httpd dead but subsys locked

These are the versions I am running:
# rpm -q php php-eaccelerator httpd
php-5.1.6-2
php-eaccelerator-5.1.4_0.9.5-0.4.rc1.fc6
httpd-2.2.3-4

Would the wrong version of eAccelerator prevent apache from running?
Has anyone else seen this problem? It must have happened within the
last weeks updates.

Thanks,
Garry


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]