[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Fedora Core 5 Test Update: kernel-2.6.17-1.2171_FC5



On Tue, 2006-08-29 at 14:14 +1000, Rodd Clarkson wrote:
> On Tue, 2006-08-15 at 18:43 -0400, Dave Jones wrote: 
> > On Wed, Aug 16, 2006 at 08:24:17AM +1000, Rodd Clarkson wrote:
> > 
> >  > Suspend and resume is still busted in this kernel on my Dell Inspiron
> >  > 9300.
> >  > 
> >  > Seems to suspend okay, but wont resume.  Keyboard is dead and the only
> >  > way to fix is to hold down the power button.
> > 
> > Some of the rawhide testers found that things broke a while ago
> > and recently started working again.  The problem is I'm not entirely
> > sure which changes are responsible.
> 
> Allow me to point a finger if I may.  I'm currently using
> kernel-2.6.17-1.2174_FC5
> 
> I (like many fedora users) use livna and in particular, since I have a
> nvidia graphics card, I use the binary nvidia supplied using livna. I
> also use updates-testing.  Recently (the last few days) I did a yum
> update and livna offered up a package for my kernel (which is currently
> in updates-testing).  This doesn't happen that often.
> 
1. the kernel you say is in updates-testing has been installed on my
machine since August 15 [1], from updates.
The livna nvidia drivers have been installed since August 19 [2]
and the latest nvidia update was installed August 26 [3]

> I booted into kernel-2.6.17-1.2174_FC5 to give it a try (since the
> nvidia driver had also been upgraded) and for a lark I tried out
> suspend/resume, only to find it worked.  I've been using
> kernel-2.6.17-1.2139_FC5 for some time since suspend/resume works and
> this makes using my laptop a lot nicer.
> 
> This got me to thinking (since you complained that this suspend and
> resume problems seems to come and go and you can't seem to pin down what
> was causing it) that maybe the problem isn't the kernel, maybe its the
> xorg-x11-drv-nv package. 
> 
> In the true spirit of a good tester, i disables the nvidia-glx service
> (which toggles xorg.conf files depending on whether or not the nvidia
> kernel module exist) and then restarted X, which start, but using the
> 'nv' driver (and not the 'nvidia' driver).  Suspend and (particularly)
> resume failed.
> 
> Restart the system, turn back on the nvidia-glx driver support and
> suspend and resume works again.
> 
> > As a worst case, hopefully a rebase to .18 when its released will fix it,
> > but hopefully before then we can figure out which patch broke things
> > and just revert that change.
> 
> So, to cut a long story short, I don't think it's a kernel related
> patch, but something to do with xorg-x11-drv-nv
> 
Or maybe kernel related but interacting with the nv driver.

> Can someone confirm this and (regardless) do I file a bug report under
> this driver?
> 
The testing you have done implies (to me) that the nv driver should have
a bug report filed on it.


$ uname -r
2.6.17-1.2174_FC5 
# grep 2174 /var/log/yum.log
[1]  Aug 15 23:43:41 Installed: kernel.x86_64 2.6.17-1.2174_FC5
[2]   Aug 19 11:39:07 Installed: kmod-nvidia.x86_64
              1.0.8762-5.2.6.17_1.2174_FC5
[3]   Aug 26 07:37:18 Installed: kmod-nvidia.x86_64
              1.0.8774-1.2.6.17_1.2174_FC5


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]