[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC6 T3 install woes



Hi,

I tested the installation CD again and I think the problem (in my case)
is the sata_promise driver. See below.

El ds 16 de 09 del 2006 a les 23:14 +0200, en/na Josep Puigdemont va
escriure:
> El ds 16 de 09 del 2006 a les 13:04 -0700, en/na listman va escriure:
> > I've tried 2 different dvd iso's (different servers and can not boot
> > either one ( FC-6-Test3-x86_64-DVD.iso)
> > Home built / ASUS A8N32-SLI Deluxe Socket 939 NVIDIA nForce SPP 100 ATX
> > AMD Athlon(tm) 64 X2 Dual Core Processor 4400+, MMX, 3DNow (2 CPUs), ~2.2GHz
> > 2048MB corsair XMS 3500LLPro
> > Seagate Barracuda 7200.10 (Perpendicular Recording) ST3250620AS 250GB 7200
> > RPM 16MB Cache SATA 3.0Gb/s
> > eVGA 256-P2-N584-AR Geforce 7900GT KO 256MB GDDR3 PCI Express x16 Video Card
> > 
> > I then downloaded the cd ISO. I got to the beginning of the install, check
> > the media (was ok) then as soon as it searches for a previous install the
> > screen goes black - can see the cursor still but it just hangs. If I go to
> > the console I see a ton of errors ( how can I export this info)
> > I have tried text and noprobe but I still get the same thing, except in
> > text only mode I cant even read the errors- its just a bunch of strange
> > characters.
> 
> I didn't have the problems you face above, but I've seen the strange
> characters in console you mentioned. Here is a picture I took of the
> screen:
> http://dsv.su.se/~icss-jpc/fedora/anaconda01.jpg
> 
> I am not 100% sure about it, but the strange characters seem to appear
> after some kernel modules are loaded (I could see raid stuff in the
> second console, although I don't have raid).

After retesting, I realize this happens right after loading the
sata_promise kernel driver. I tested several times with and without the
SATA controller enabled in the BIOS, and the strange characters _always_
appear once the sata_promise is loaded.

Related to this problem, I've previously filed a bug (#199142) against
the kernel for FC5 (all 2.6.17 kernels have this problem for me). When
booting, I could see a "unable to handle kernel NULL pointer
dereference" message. Disabling the SATA controller makes this error
message disappear. I think there must be some bug in that driver that
causes the two problems.

The sata controller that I disabled on the BIOS is P20579. My
motherboard is microstar K8T Neo 2. For more info, the whole output of
lspci is on the bug report mentioned above.


> 
> The big blue area in the middle of the screenshot is due to the media
> check dialog (which I ran, and was ok). I can't remember if the
> characters in the media check dialog where also strange or not. I think
> they were, but then how could I say that the media check was ok...

I was wrong, I can confirm that the media check messages were actually
clear text:
http://dsv.su.se/~icss-jpc/fedora/anaconda02.jpg


> As it can be seen at the bottom, before starting the graphical installer
> the characters appear normally. The rest seemed to work fine (I didn't
> do the whole install).

During one of the tests, I had the problem with the black screen. When
the graphical installer is to start, the screen went black and couldn't
do anything, neither could I see the mouse pointer, nor could I go back
to the text consoles. I had to reset the computer. That could be the
memory corruption Paul mentions (BZ #206472), but I could not reproduce
it, it's strange that only happened once out of 10 tests I did (I would
expect it to be more deterministic).

Is there a bug report filled about the strange characters, by the way?

Hope it helps.

/Josep



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]